PRNEGA programos paskirtis

PRNEGA programos HELPas

Paskirtis

PRNEGA programa yra skirta TV kreipiamųjų sistemų (KS) gamybos logistikai, elektroninių-optinių parametrų analizei masinėje gamyboje. Pagrindinis tikslas - palengvinti derintojų ir technologų darbą.

Galimybės
  • Instaliuoti duomenų bazes (DB) pasirinktam gamybiniam kompleksui ir pasirinktiems parametrams.
  • Suformuoti gamybinių objektų komplektą su dinamikos parametrais.
  • Importuoti ar įvesti matavimų bei metrologinius duomenis su gam. objektais eliminuojant klaidingus matavimus.
  • Įvertinti pataisas, koeficientus, gamybines parametrų normas.
  • Paskaičiuoti asimetrijas, statistikas, dinamiką įvairiems objektams.
  • Analizuoti duomenis ir suformuoti ataskaitas.
  • Nukopijuoti ir pernešti duomenis į kitą kompiuterį bei pasinaudoti kompiuteriniu tinklu analizuojant parametrus įvairiose darbo vietose.
  • Eksportuoti duomenis į įvairių tipų rinkmenas, kad lengviau galima būtų pritaikyti alternatyvias programas.

Turinys
Sąlygos Sąlygos Valdymas Valdymas Terminai Terminai Mokymas Mokymas Istorija Istorija Nuorodos Nuorodos

Šis HELPo Projektas pastoviai bus papildomas ir tikslinamas bei koreguojamas tolesnio bendradarbiavimo su autoriumi eigoje. Helpas suformuotas ir gali būti naudojamas vietoj instrukcijos. Papildymai bus diegiami, jei kompiuteris prijungtas prie bendrovės kompiuterinio tinklo ir su Informatikos sk. suderintas sujungimas per Microsoft tinklą. Pakeitimų archyvus dar galima pasiimti iš Vingis2 serverio.

Programos autorius: Siūsk el. laiską !!! V. Šaras


PRNEGA programos panaudojimo sąlygos

Prieš PRNEGA programos panaudojimą, įdėmiai perskaityk šias sąlygas. Jei nesutinki su jomis, privalai ištrinti šios programos kopiją su visu Vnes katalogo turiniu.

Algoritmai ir programa buvo kuriami, panaudojami ir papildomi bei tobulinami nuo 1987 metų AB "Vilniaus Vingis". Atskiriems projektavimo etapams buvo pasirašytos autorinės sutartys.

Norėdami instaliuoti ir panaudoti šią programą, Jūs privalote paduoti paraišką - pagrindimą Informatikos skyriui ir kopiją technikos direktoriui. Informatikos skyriaus atstovai tai padarys ir užregistruos. Turi būti nurodytas atsakingas asmuo, vieta ir kompiuterinio tinklo poreikis bei vardas su slaptažodžiu. Kompiuterinio tinklo atveju kompiuteris turi būti konfiguruotas taip, kad tinklo pagalba galima būtų atlikti autorinę priežiūrą ir naujų versijų instaliavimą. Smulkiau skaitykite metodinėje instrukcijoje "PROGRAMINĖS ĮRANGOS PARENGIMAS, DIEGIMAS IR APSKAITA". Ją galite rasti bendrovės kompiuteriniame tinkle "T:\MI\mi_veik\mi05720.doc" arba "T:\MI\mikatalogas.doc "

Šios programos panaudojimas reikalauja žinių apie kreipiamųjų sistemų elektroninius - optinius ir statistikos parametrus. Ataskaitų ruošimas reikalauja darbo principų su "Excel" elektroninių lentelių programa žinojimo.

Kompiuteris turi būti konfiguruotas taip, kad suprastu skaitmeninius laukus su tašku vietoj kablelio. Ruošiant ataskaitas Excel elektroninės lentelės pagalba reikia iš Tools - Options - General ištrinti lauką Default file location, kad failai būtų ieškomi tame pačiame kataloge, kuriame dirba programa. Excel vieta ir ataskaitų paleidimo komandos turi būti nurodytos programos parametruose.

ŠI PROGRAMA IŠBANDYTA AB "VILNIAUS VINGIS" KOMPIUTERIŲ PARKE , WIN95, WIN98 su lietuviškais priedais IR WINXP SISTEMŲ APLINKOSE BEI MICROSOFT KOMPIUTERINIAME TINKLE . RAM NE MAŽIAU 16MB , TURI BŪTI INSTALIUOTAS IE4 (AR AUKŠTESNĖS VERSIJOS), HDD IR PROCESORIAUS SPARTOS PARINKIMAS PRIKLAUSO NUO APDOROJAMŲ DUOMENŲ KIEKIO .

NELEIDŽIAMA keisti šios programos, ar dekompiliuoti. Bet kokios dalies panaudojimas kitiems tikslams, negu čia paminėta, kopijavimas ir modernizavimas turi būti suderintas su Informatikos skyriumi ir autoriumi.

Programa gali būti tobulinama, papildoma, atnaujinama ar pratęsiama nuo 2006.10.01 tariantis su autoriumi žemiau nurodytu adresu. Atnaujinimus galima rasti bendrovės kompiuteriniame tinkle.

Klausimus galite siūsti arba į AB "Vilniaus Vingis", arba pasinaudojant bendrovės vidiniu intranetu, arba autoriui: V_Sharas@yahoo.com arba konsultantams: Kjan@vingis.lt ar Tlilija@vingis.lt


Kreipimo sistema

Kreipimo sistema (KS)

KS sudaro dvi poros kadrų ritelių (kr) ir dvi poros eilučių ritelių (er), kurios išdėstytos simetriškai ir statmenai viena kitai. Televizoriuje tekant pro šias riteles srovei, sukuriamas magnetinis laukas, kuris veikia tris kineskopo elektronų spindulius, skirtus atskiroms spalvoms (b, g ir r – iš žodžių blue, green ir red). Kadrų ritelės kreipia spindulius vertikaliai, eilučių ritelės horizontaliai (y ir x kryptimis).

Elektroniniai-optiniai parametrai - EOP , gaunami sąveikaujant KS ir kineskopui bei veikiant į ekraną nukreiptą elektronų spindulį specialiai suformuotais magnetiniais ir elektriniais laukais.

Kineskopo ir KS supaprastinta schema


PRNEGA valdymas

PRNEGA programos valdymas

Programa valdoma meniu sistemos ir komandinių mygtukų pagalba.

DB instaliavimas

Duomenų įvedimas.

Skaičiavimų atlikimas.

Duomenų analizė.

Ataskaitos.


Meniu sistema

Programos Meniu sistema tai:
Pirminių duomenų meniu komplektas
tai:
  • Pirmin. DB lentelių redagavimas
  • 'Minoltos' nesuvesties importas
  • VDT duomenų importas
  • Pirm.duomenų rinkinys
  • Pataisų perskaičiavimas
  • Statistikos skaičiavimas
  • KS parametrų skaičiavimas
  • Partijos statistika
  • Pirminių duomenų šalinimas
  • Pirmin.duomenų DB instaliavimas

    • KS asimetrijų meniu komplektas
    tai:
  • KS nesusiv.ir asim.naršyklė
  • 'Vingelio' nesuvesties importas
  • IPS duomenų importas
  • KAMAYA duomenų importas
  • Nes.def.normos ir pataisos
  • Asim.def.normos ir pataisos
  • KS asimetrijų skaičiavimas
  • Asimetr.opt.normų sk.zonose
  • Visų asimetr.opt.normų sk.
  • KS statistikos skaičiavimas
  • Statistikos eksportas
  • Eksporto duomenų dalinimas
  • KS nes.ir asim.duomenų šalinimas
  • KS nes.ir asim. DB instaliavimas

    • KS asimetrijų optimumo meniu komplektas (prieinamas tik gamybos biurui)
    tai:
  • Opt. naršyklė
  • Visos procedūros
  • Gamybos obj. importas
  • Gam. objektų žymėjimas
  • Optim. asim. skaičiavimas
  • Asim. šalinimas iš optim.
  • Optimumų analizė
  • Xls. grafikai
  • Gam.obj.surink.variantai
  • Par. opt. duomenų šalinimas
  • Par. optimizavimo DB instaliavimas

    • KS gamybos įrengimų derinimo meniu komplektas (prieinamas tik gamybos biurui)
    tai:
  • Gamyb.įrengim.par.naršyklė
  • Gam.įreng.skirtumų.naršyklė
  • Gam.įreng.datos ir laiko tikrinimas
  • Gam.įreng.datos su 23val taisymas
  • Gam.įreng.duomenų papildymas
  • Gamybos įreng.Kamayos nes.importas
  • Gam,įreng.duomenų ataskaita
  • Gam.įreng.skirtumų skaičiavimas
  • Asim. perrašymas į bendras lent.
  • Gam.įreng ir asim.eksportas
  • Gam.įrengim.žym.įrašų ŠALINIMAS
  • Asimetrijų skirtumo ŠALINIMAS
  • Asim.ir skirtum.Bendrų duom.ŠALINIM
  • Ryšio su NESUV. duom.Šalinimas
  • Gam.įreng.VISŲ duom.ŠALINIMAS

    • Gamybos kontrolinių surinkimų meniu komplektas
    tai:
  • Kontr.surink. parametrų naršyklė
  • Kontr.surink. ataskaitos
  • Ataskaitos EOP pasirinkimas
  • Kontr.surink. imčių kompl. formavimas
  • Kontr.surink. imties formavimas
  • Kontr.surink. param.skaičiavimas
  • Pažymėtų kontr.surink. šalinimas
  • Kontr.surink. duomenų šalinimas
  • Kontr.surink. DB instaliavimas

    • Gamybos objektų meniu komplektas
    tai:
  • Gam. objektų parametrų naršyklė
  • Gam. objeto elektr. lentelė
  • Minimalus nesusivesties tinkamumas
  • Minimalus asimetrijų tinkamumas
  • Mėn. parametrų naršyklė
  • Mėn. parametrų registravimas
  • Gam.obj. param. importas
  • Gam. objektų param.skaičiavimas
  • DB lent.profilaktinis perrūšiavimas
  • Pažymėtų gam.objektų šalinimas
  • Gam. objektų duomenų šalinimas
  • Gam. objektų DB instaliavimas

    • Procedūrų meniu komplektas
    tai:
  • Prad. duomenų instaliavimas
  • Nuo Minoltos duomenų iki ataskaitos
  • Duomenų eksportas ar importas
  • Profilaktinis prad. ir nes. duomenų šalinimas
  • Visų DB šalinimas
  • Ekrano valymas
  • Duomenų archyvavimas
  • DB lentelės taisymas
  • DB lentelių apžvalgos naršyklė
  • TXT bylų redagavimas

    • Darbo režimų meniu komplektas
    tai:
  • Gaminio katalogas
  • KS Nesuv. normos
  • KS Asimetrijų normos
  • Gam.objektų imtys
  • Kompl. ir išskirt. objektai
  • Progr. darbo rėž. parametrai
  • Pr. darbo rėž. parametrai
  • Fox Pro lango atidarymas
  • Fox Pro lango uždarymas

    • Apie programą, pagalba ir išėjimo meniu pasirinkimai
    tai:
  • Apie programą
  • Pagalba
  • Išėjimas


Duomenų struktūra

Labai svarbu yra įsisavinti EOP bei kitų duomenų sudedamasias dalis ir struktūrą, kad galima būtų efektyviai valdyti gamybos procesą ir gaminių kokybę. Dėl to būtina kuo prieinamiau, paprastai ir aiškiai pateikti veikimo principą bei išdėstyti parametrus.

Darbo režimai Matavimo zonos ir duomenų išdėstymas.

Darbo režimai Programos darbo pradiniai duomenys

Darbo režimai Nesuvesties ir skleistinės pirminiai duomenys.

Darbo režimai EOP iškraipymai.

Darbo režimai EOP Asimetrijos.

Darbo režimai Statistikos parametrai.

Darbo režimai DB sudėtis

Darbo režimai Gamybiniai objektai.


Matavimo zonos ir duomenų išdėstymas

Darbo režimai Kreipimo sistema (KS)

Kadangi įvairiose zonose vaizdo parametrai (EOP) skiriasi, matuojant ekranas suskirstomas į zonas. Įvairiose firmose zonos žymimos skirtingai. Žemiau išvardinti dažniausiai naudojami zonų žyminiai. Žyminiams gali būti naudojami zonų eilučių ir stulpelių numeriai, laikrodžio valandų numeriai, kairės - dešinės - viršaus - apačios žodžių pirmosios raidės, šiaurės - pietų - rytų - vakarų žodžių pirmosios raidės, pirmosios raidės gali būti iš atitinkamos firmos naudojamos kalbos žodžių ir panašiai.

Kompiuteriniai PRNEGA programos ekrano vietos adresai:

11 | 12 | 13 | 14 | 15 | 16 | 17
21 | 22 | 23 | 24 | 25 | 26 | 27
31 | 32 | 33 | 34 | 35 | 36 | 37
41 | 42 | 43 | 44 | 45 | 46 | 47
51 | 52 | 53 | 54 | 55 | 56 | 57
61 | 62 | 63 | 64 | 65 | 66 | 67
71 | 72 | 73 | 74 | 75 | 76 | 77

Eiliniai |  |  | Valandiniai
1 | 2 | 3 | 10 | 12 | 2
4 | 5 | 6 | 9 | 0 | 3
7 | 8 | 9 | 8 | 6 | 4
Krypties |  |  | Anglų k.
KV | V | DV | NW | N | NE
K | C | D | W | C | E
KA | A | DA | SW | S | SE

Krypties plačioji

RVK |  |  |  |  |  | RVD
 | VK | TVK | V | TVD | VD |
 | GVK | CVK | OV | CVD | GVD |
 | K | OK | O | OD | D |
 | GAK | CAK | OA | CAD | GAD |
 | AK | TAK | A | TAD | AD |
RAK |  |  |  |  |  | RAD

Sutartinė

P2' |  |  |  |  |  | P1'
 | P2 | S12 | Y1 | S11 | P1 |
 | S32 | S22 |  | S21 | S31 |
 | X1 |  | A |  | X2 |
 | S33 | S23 |  | S24 | S32 |
 | P3 | S13 | Y2 | S14 | P4 |
P3' |  |  |  |  |  | P4'

Samsungo plačioji

TL’ |  |  |  |  |  | TR’
 | TL | TTL | T | TTR | TR |
 | LTL | MTL |  | MTR | RTR |
 | L |  | C |  | R |
 | LBL | MBL |  | MBR | RBR |
 | BL | BBL | B | BBR | BR |
BL’ |  |  |  |  |  | BR’

Filipso |  |  |  |  |
F | K |  | D |  | L | G
F' | S | s' | W | t' | T | G'
B | P | p' | A | r' | R | C
H' | U | u' | Z | v' | V | J'
H | M |  | E |  | N | J

Thomsono
10 | 11 | 12 | 01 | 02
09:30 | 10A | 12A | 02A | 02:30
09 | 09A | 0 | 03A | 03
08:30 | 08A | 06A | 04A | 03:30
08 | 07 | 06 | 05 | 04

Dažniausiai naudojami zonų komplektai ir jų žyminiai

Dažnai dar zonos komplektuojamos ir komplektai turi savo žyminius.

Dažniausiai naudojami zonų komplektai ir jų žyminiai:

 | S0 |  |  | S1 |  |  | S2 |  |  | S3 |
22 | 24 | 26 | 23 | 24 | 25 | 33 | 24 | 35 | 32 | 24 | 36
42 | 44 | 46 | 42 | 44 | 46 | 42 | 44 | 46 | 42 | 44 | 46
62 | 64 | 66 | 63 | 64 | 65 | 53 | 64 | 55 | 52 | 64 | 56

Zonų nesuvesties atstumo tarp spindulių koordinačių išdėstymas kompiuterinėse duomenų bazėse ir ataskaitų formose:

GRx | GBx | GRy | GBy
1 | 2 | 3 | 4

arba

GR x | GB x | 1 | 2
GR y | GB y | 3 | 4


Nesuvesties ir skleistinės pirminiai duomenys

Pirminiai duomenys gaunami išmatavus KS parametrus. Šie matavimai gali būti atliekami gamybos proceso kontrolės metu, gamybos proceso eilinės operacijos metu, kontrolinių surinkimų metu ar specialių (pvz metrologinių ar kitų) tyrimų metu.

Priklausomai nuo to, su kokiu įrenginiu atliekami matavimai ir kokie tų matavimų tikslai, skiriasi pirminių duomenų struktūra.

Vieni matavimo įrenginiai ir jų valdymo kompiuterinės programos leidžia keisti matuojamų parametrų sudėtį, kiti skirti pastoviam, nekeičiamam panaudojimui. Nuo įrenginio ir parametrų kiekio bei išdėstymo būdo priklauso pirminių duomenų struktūra. Paeiliui matuojant KS, pirminių duomenų struktūra kartojasi nesikeisdama, o keičiasi tik vis kitos KS parametrų dydžiai. Jei struktūra pasikeitusi, tai konstatuojama klaida ar nebaigtas matavimas ir šios KS duomenys ignoruojami.

Dažniausiai panaudojamas tekstinis matavimo duomenų užrašymo ir išsaugojimo kompiuterinis būdas. Tai reiškia, kad su paprasčiausiu tekstiniu redaktoriumi galima pasižiūrėti ir analizuoti pirminius duomenis, kurie randasi tekstiniame faile. Tačiau tai reikalauja atitinkamų žinių ir nėra patogus. Daug patogiau pasinaudoti KS duomenų importu į DB ir pasinaudoti tam skirtomis programų formomis ir atitinkamais parametrais bei jų statistikiniais įvertinimais.

Pastaba: Kadangi dar panaudojami seno tipo kompiuteriai, tai Windows sistemą reikia suderinti dešimtainio skaičiaus atvaizdavimui su tašku, o ne kableliu.

Darbo režimai Matavimo zonos ir duomenų išdėstymas kineskopo ekrane.

Darbo režimai KS duomenų importas


EOP iškraipymai

Kadangi kreioiamųjų sistemų (KS) elektroniniai optiniai parametrai (EOP) priklauso nuo didelio skaičiaus įvairių gamybos faktorių ir panaudojamų medžiagų sąvybių, labai svarbu metodiškai ir kuo paprasčiau suskirstyti EOP į rūšis ir asimetrijas.

1 - tikslus vaizdas; 2 - sferinė aberacija; 3 - koma; 4 - astigmatizmas; 5 - 6 - distorsija.

KS gamybos proceso metu yra atliekamas įrengimų ir viso proceso derinimas remiantis astigmatizmo, komos ir distorsijos EOP. Astigmatizmas nustatomas ir skaičiuojamas matuojant raudono ir mėlyno (kraštinių) spindulių pėdsakus, koma nustatoma ir skaičiuojama matuojant žalio ir raudono su mėlynu (centrinio ir kraštinių) spindulių pėdsakus ir distorsija arba geometriniai skleistinės iškraipymai nustatomi ir skaičiuojami matuojant žalio spindulio pėdsako atstumus nuo kaukės rėmelio ar videodaviklių centro.

Astigmatizmas ir paviršiaus iškreivinimas.

Komos aberacija.

Kiekviena iš paminėtų iškraipymų rūšių dar yra dalinama į asimetrijas:

Darbo režimai EOP Asimetrijos.


EOP Asimetrijos

EOP asimetrijos programoje paskaičiuojamos po EOP pirminių duomenų įvedimo, pataisų perskaičiavimo ir KS parametrų skaičiavimo. PRNEGA programoje kiekvienoje asimetrijų rūšyje jie sunumeruoti nuo 1 iki 40.

Ekrano formose jie išdėstomi griežta, žemiau nurodyta tvarka. Kiekvienoje eilutėje ar stulpelių grupėje randasi atitinkamo iškraipymo ir atitinkamų faktorių rūšies poveikio parametrai.

Visų pirma visos asimetrijos skirstomos į astigmatizmo, komos ir skleistinės geometrinių iškraipymų parametrų rūšis. Skleistinės geometrinių iškraipymų ar distorsijos parametrai gaunami veikiant dvipoliam magnetiniam laukui, astigmatizmo parametrai gaunami veikiant keturpoliam magnetiniam laukui ir komos parametrai gaunami veikiant šešiapoliam magnetiniam laukui.

Kiekvienoje asimetrijų rūšyje parametrai skaidomi į parametrus ant horizontalios ar vertikalios ašies (pirmoji eilutė), kampuose (antroji ir trečioji eilutės) ir anizotropijos parametrus (ketvirtoji ir penktoji eilutės). Sudėjus visus vienos eilutės parametrus ant ašių ar kampuose, gaunami pirminiai nesuvesties parametrai ant ašių ar kampuose. Dėl to šis skaidymas į aštuonis parametrus ir atitinkamas grupes yra pilnas.

Stulpeliuose (po 2 stulpelius) asimetrijos parametrai sugrupuoti pagal ritelių arba kineskopo optikos detalių asimetrijų kryptį. Apatinėje piešinio eilutėje nupieštos ritelių vijų asimetrijų galimos kryptys kiekvienai grupei bei asimetrijų pavadinimai ir sutartiniai žyminiai. Jie dažnai vadinami efektais (M, D, N, W).

Komos ir geometrijos parametrai piešinyje nurodyti viename skirsnyje kadangi sutampa asimetrijų kryptys.

Darbo režimai Asimetrijų logika

Darbo režimai Asimetrijų rūšiavimas

Darbo režimai EOP iškraipymai

Darbo režimai Matavimo zonos ir duomenų išdėstymas

Darbo režimai Nesuvesties ir asimetrijų algoritmai


Statistikos parametrai

Vidurkis (avg) ir vidurkio išsibarstymas

Standartinis išsibarstymas (std)

Gamybos tinkamumo koeficientas (cpk)

Normalusis pasiskirstymas ir patekimo į intervalą tikimybė

Defektingumų sumavimas

Pasiskirstymo asimetrijos

Dviejų parametrų koreliacija

Dinamikos parametrai gaunami skaičiuojant statistikos parametrus trims skirtingoms imtims. Skirtingos imtys atspindi skirtingus gamybos periodus, priklausomai nuo įvestų duomenų datos ir laiko. Skirtingiems objektų tipams įvedamos skirtingos imtys.


DB sudetis

Duomenų Bazės (DB) sudėtis

Duomenų bazės kompleksas instaliuojamas šios programos pagalba ir gali būti suformuotas pagal poreikius bet kuriame VNES katalogo subkataloge.

Priklausomai nuo reikalingų analizės rezultatų gali būti suformuotas atitinkamos sudėties DB kompleksas. Apie DB pavadinimus žr. čia.

Analogiškai meniu komplektams, yra galimybė instaliuoti DB kompleksą iš penkių DB:

Pirminių duomenų DB (Piln.dbc)

tai lentelės:
  • Pilnobj.dbf - pirminių nesusivesties duomenų gamybos objektų sąrašas kiekvienai išmatuotai KS;
  • Pilnes.dbf - pirminiai spalvotų spindulių nesuvesties koordinačių duomenys kiekvienai išmatuotai KS ir statistikos parametrai;
  • Pilgeo.dbf - pirminiai žalio centrinio spindulio skleistinės koordinačių duomenys kiekvienai išmatuotai KS ir statistikos parametrai;
  • Pilrkt.dbf - pirminiai induktyvumo, varžos ir ryšio koeficiento duomenys kiekvienai išmatuotai KS (kol kas nepanaudojama, kadangi matavimų gamybinis procesas aparatūriškai neapjungtas su nesuvestimi ir geometrija) ir statistikos parametrai;
  • Pinorpat.dbf - KS parametrų limitai (normos), pataisos (pataisos) ir centrinės nesuvesties perskaičiavimo koeficientai (statikos koeficientai)
  • Dfkompl.dbf - pradinių duomenų komplekto sudėtis, kiekis ir vieta.

    • KS asimetrijų DB (Nes.dbc)

    tai lentelės:
  • Nesobj.dbf - nesuvesties asimetrijų duomenų gamybos objektų sąrašas kiekvienai išmatuotai KS;
  • Astasis0.dbf, Astasis1.dbf, Astasis2.dbf, Astasis3.dbf - astigmatizmo asimetrijų duomenys kiekvienai išmatuotai KS ir statistikos parametrai atitinkamose zonų komplektuose;
  • Astness0.dbf, Astness1.dbf, Astness2.dbf, Astness3.dbf - astigmatizmo nesuvesties koordinačių duomenys kiekvienai išmatuotai KS ir statistikos parametrai atitinkamose zonų komplektuose;
  • Disasi.dbf, Disnes.dbf - skleistinės (žalio spindulio atžvilgiu kaukės) asimetrijų ir nesuvesties koordinačių duomenys kiekvienai išmatuotai KS ir statistikos parametrai;
  • Komasis0.dbf, Komasis1.dbf, Komasis2.dbf, Komasis3.dbf - komos asimetrijų duomenys kiekvienai išmatuotai KS ir statistikos parametrai atitinkamose zonų komplektuose;
  • Komness0.dbf, Komness1.dbf, Komness2.dbf, Komness3.dbf - komos nesuvesties koordinačių duomenys kiekvienai išmatuotai KS ir statistikos parametrai atitinkamose zonų komplektuose;
  • Norma.dbf, Normn.dbf - parametrų tikslo ir limitų (normų) dydžiai (kol kas nenaudojami);
  • Param.dbf - pradinų bei darbo režimo duomenys
  • Asimnorm.dbf - asimetrijų opt.normų skaičiavimo duomenys
  • Asimlaik.dbf - asimetrijų opt.normų skaičiavimo tarpiniai duomenys

    • KS asimetrijų optimumo DB (Optasim.dbc)

    tai lentelės:
  • Optobj.dbf - analizuojamų ir pasirinktų gamybos objektų sąrašas su imties dydžio ir gamybos terminų duomenimis;
  • Optata.dbf - optimumų analizės rezultatų lentelė;
  • Optpap.dbf - prie kiekvieno iš efektų standartinio komplekto papildomai pasirenkamų parametrų sąrašas;
  • Krm.dbf, Erm.dbf, Krd.dbf, Erd.dbf, Krn.dbf, Ern.dbf, Krw.dbf ir Erw.dbf - kikvieno iš aštuonių efektų komplektų parametrai išmatuotiems gaminiams;
  • Krms.dbf, Erms.dbf, Krds.dbf, Erds.dbf, Krns.dbf, Erns.dbf, Krws.dbf ir Erws.dbf - kikvieno iš aštuonių efektų komplektų optimumo statistikos parametrų skaičiavimo rezultatai kiekvienam pasirinktam gamybos objektui.

    • Gamybos kontrolinių surinkimų DB (Kons.dbc)

    tai lentelės:
  • Konspil.dbf - kontrolinių surinkimų pradinių nesuvesties duomenų statistika gamybos objektams;
  • Konsasi.dbf - kontrolinių surinkimų astigmatizmo ir komos asimetrijų atitinkamose zonų komplektuose duomenų statistika gamybos objektams;
  • Konsnes.dbf - kontrolinių surinkimų astigmatizmo ir komos nesuvesties atitinkamose zonų komplektuose duomenų statistika gamybos objektams;
  • Konsgeo.dbf - kontrolinių surinkimų skleistinės iškraipymų duomenų statistika gamybos objektams;
  • Konsobj.dbf - kontrolinių surinkimų gamybos objektai.

    • Gamybos objektų DB (Gam.dbc)

    tai lentelės:
  • Gasi.dbf - gamybos objektų astigmatizmo, komos ir skleistinės asimetrijų atitinkamose zonų komplektuose duomenų statistika;
  • Gnes.dbf - gamybos objektų astigmatizmo, komos ir skleistinės nesuvesties atitinkamose zonų komplektuose duomenų statistika;
  • Gblr.dbf - gamybos objektų induktyvumo, varžos ir ryšio koeficiento duomenų statistika;
  • Gamobj.dbf - gamybos objektų ir dinamikos duomenys;
  • Gamtipst.dbf - gamybos objektų tipų ir dinamikos formavimo duomenys;
  • Kompl.dbf - kompleksinių objektų formavimo duomenys;
  • Gmen.dbf - per mėnesį sukauptų (mėnesinių) duomenų statistika;
  • Bparalg.dbf - atskirų skaičiavimo algoritmų duomenys.

    • Kiekviena iš šių DB susideda iš DB lentelių ir turi savo failus.

    Kiekviena DB lentelė susideda iš laukų (stulpeliuose) ir įrašų (eilutėse).

    Procedūrų meniu komplektas turi DB lentelių apžvalgos naršyklės meniu punktą, kuriame galima pasirinkti bet kurią lentelę ir pasižiūrėti jos sandarą ir tūrinį.


Gamybiniai objektai

Gamybiniai objektai PRNEGA programoje yra skirstomi pagal gamybos proceso nuoseklių veiksmų paskirtį ir to proceso derinimo atlikimo galimybes. Tai žemiau išvardinti gamybiniai objektai, kurie dalyvauja gamybiniame procese ir registruojami pirminiuose duomenyse ir arba skaičiuojami parametrai gamybinių objektų DB.

Pirminiuose duomenyse panaudojami žyminiai:

bar - gamybinio baro numeris (3 skaičiai) arba gaminamo produkto partijos numeris;

fer - feritinės šerdies tiekėjas (3 simboliai);

lai - ritelei panaudojamo laido tiekėjas (3 simboliai);

enr - eilučių ritelės vyniojimo įspraustinės numeris, kiekvienai pamainai kitas (3 skaičiai);

knr - kadrų ritelės vyniojimo staklių laikiklio numeris (4 skaičiai);

kor - korpuso liejimo formos numeris (4 skaičiai);

jus - derintojo (justuotojo) numeris (3 skaičiai);

kon - kontrolės numeris (4 skaičiai);

kin - kineskopo numeris (9 skaičiai);

pav - operatoriaus pavardė ar inicialai (10 simbolių);

Gamybinių objektų DB panaudojami papildomi žyminiai:

ben - bendri statistikos parametrai visiems gamybos objektams;

enk - eilučių ritelių vyniojimo įspraustinės numeris, visoms pamainoms tas pats (3 skaičiai);

knk - kadrų ritelių vyniojimo staklių su visais laikikliais numeris (4 skaičiai);

kna - kadrų ritelių vyniojimo staklių laikiklių aukšto numeris (4 skaičiai);

kns - kadrų ritelių vyniojimo staklių laikiklių stovo numeris (4 skaičiai);

map - skirtingo tipo matavimo prietaisų statistikos parametrai;


Duomenų įvedimas

Duomenų pirminiam nuskaitymui ir įvedimui gali būti panaudoti įvairūs tam skirti įrengimai. Vienas iš jų - Minoltos matuoklis.

Šiam matuokliui skirta speciali programa minolta.exe arba gali būti panaudotos kitos programos, pvz. Stefanovičiaus.

Duomenų nuskaitymui ir KS derinimui dažniausiai panaudojamas Vingelio įrenginys.

Kol kas didžiausią EOP komplektą formuoja Kamayos matuoklis.

Matavimai gali būti atlikti ir su IPS matuokliu.

Prieš duomenų įvedimą, turi būti VNES direktorijos aplinkoje sukurta ar pasirinkta subdirektorija - vieta, kurioje bus saugomi atlikto darbo rezultatai:

Darbo režimai instaliuojama DB Darbo režimai atliekami skaičiavimai Darbo režimai formuojamos atskaitos


DB instaliavimas

Prieš instaliavimą turi būti apsispręsta, kokioje VNES direktorijos subdirektorijoje (kataloge) bus saugomi duomenys ir rezultatai. Subdirektorijų pavadinimus tikslinga trumpinti ir formuoti panaudojant angliškos abėcėlės raides be tarpų, nes tuomet neveikia kai kurios komandos ir programos procedūra gali rodyti klaidas.

Tuomet šioje subdirektorijoje paleidžiama PRNEGA programa, arba meniu sistemos pagalba pasirenkamas gaminio katalogas. Jei bus panaudoti papildomi parametrai su tarpinėm geometrijos zonom, tai panaudojama PRNEGATOM programa (skirta f. Thomson gaminiams).

Jei šis katalogas tuščias, jame dar nebuvo atliekamos programos procedūros, tai programa į jį nukopijuoja sisteminius failus su plėtiniais .sys ir .alg iš VNES direktorijos. Tai yra tekstiniai failai, kuriuos, esant pakankamam patyrimui, galima redaguoti su esamu tekstiniu redaktoriumi. Tai yra pradiniai instaliavimo duomenys su pradiniais parametrais ir programos darbo režimais. Juos dar galima bus keisti su atitinkamomis programos formomis vėliau, kai bus instaliuotos DB.

Procedūrų meniu komplekte pasirenkamas pradinių darbo režimų duomenų importas ir šios procedūros pagalba importuojami programos darbo režimai.

Toliau galima instaliuoti duomenų bazes (DB). Kiekvienas iš pradinių trijų meniu komplektų bei kontrolinių surinkimų ir gamybos objektų meniu komplektai turi atitinkamas DB instaliavimo ir valdymo procedūras. Paskutinis meniu punktas yra instaliavimo procedūra, o priešpaskutinis - DB lentelių valymo procedūra. Pirmieji meniu komplekto punktai skirti naršymo po DB formas.

Priklausomai nuo atliekamo darbo tikslų, nereikia instaliuoti visas DB , o tik reikalingas.

Toliau atliekamas pradinių darbo režimų duomenų importas į instaliuotas DB ir jų koregavimas.


Pradinų duomenų įvedimas

Pradinų bei darbo režimo duomenų įvedimas

PRNEGA programa gali dirbti įvairiuose režimuose, priklausomai nuo gaminamo produkto (gaminio) parametrų, užsakovo reikalavimų, panaudojamų gamybinių objektų, statistikos parametrų bei programą panaudojančio personalo tikslų.

Šie duomenys įvedami ir koreguojami keliais etapais:

  1. Nukopijuojami reikalingi pirminiai sisteminiai failai.
  2. Importuojami duomenys, reikalingi DB instalaicijai,
  3. Importuojami duomenys, reikalingi duomenų apdorojimui ir programos darbui,
  4. Atliekamas pradinių ir darbo režimų duomenų koregavimas.

Pirmasis etapas atliekamas automatiniu būdu, kai pasirenkama nauja darbo direktorija. Tuomet iš VNES direktorijos nukopijuojami reikalingi failai su .sys ir .alg plėtiniais. Tai tekstiniai failai ir juos, esant pakankamam patyrimui, galima redaguoti su bet kokiu tekstiniu redaktoriumi.

Antrasis etapas atliekamas pasirinkus Procedūrų meniu komplekte esantį pradinių darbo režimų duomenų importą. Šios procedūros pagalba importuojami programos darbo režimų parametrai, esantys param.sys faile. Tuomet programa leidžia ar neleidžia atlikinėti atitinkamas procedūras.

Trečiasis etapas atliekamas po DB instaliacijos, to pačio meniu punkto pagalba. Į instaliuotas DB lenteles importuojami likusieji parametrai. Programos komentarų lange yra pateikiama informacija apie atliekamus veiksmus.

Ketvirtasis etapas - tai pradinių ir darbo režimų duomenų koregavimas kuris apima daugelio programos procedūrų algoritmus ir nagrinėjamas atskirame puslapyje.


Nesuvesties ir asimetrijų normos

Gamybos valdymui ir kontrolei yra svarbios analizuojamų parametrų normos - parametrų leistinos ribos. Nesuvesties parametrams normos nurodomos gaminio specifikacijoje. Asimetrijoms nustatomos gamybos proceso metu.

Instaliavus duomenų bazes, importuojamos normos pagal nutylėjimą, kurios randasi rinkmenose su išplėtimu .sys. Kiekvienam gaminiui būna skirtingos normos, dėl to jas reikia koreguoti arba kopijuoti iš kito katalogo. Rinkmenų pavadinimai nurodyti Duomenų Bazės (DB) sudėtyje .

Pirminių duomenų DB normos koreguojamos Pirmin. DB lentelių redagavimas meniu punkto pagalba, kur yra du pasirinkimai: Nesuv. normų koregavimas ir Pataisos, normos, koeficientai. Pastarasis pasirinkimas realizuoja normų perkėlimą į simetrines ekrano zonų vietas.

Toliau koregavimo palengvinimui yra meniu punktai Nes normų perkėlimas KS bei Nesuv. normos į asim. normas. Jų pagalba normos perkeliamos astigmatizmo ir komos normoms ir asimetrijoms. Keliant normas iš nesuvesties į asimetrijas panaudojami atitinkami koeficientai. Geometrijos (distorsijos) normų įvedimui yra speciali forma pasiekiama meniu punktu Geometrijos normų įvedimas. Ši forma pritaikyta įprastiems geometrijos iškraipymų pavadinimams ir yra realizuotas paskaičiavimo su koeficientais algoritmas kitiems kompiuteriniams distorsijos parametrams.

KS DB yra meniu punktai Nesuv. normos ir pataisos bei Asm. normos ir pataisos, kur jas galima apžvelgti ir koreguoti atskirai kiekvienam zonų komplektui (S0, S1, S2, S3). Be to čia dar yra meniu punktai Asimetr.opt.normų sk.zonose bei Visų asimetr.opt.normų sk. kur galima paskaičiuoti ir pakoreguoti optimalias asimetrijų normas. Asimetr.opt.normų sk.zonose formoje realizuotas ne tik trijų algoritmų opt. normų skaičiavimas, bet ir algoritmo atspindėjimas spalva: žalia fono spalva pažymėtas žemo defektingumo lygio algoritmas, geltona - vidutinio defektingumo ir oranžine žymaus defektingumo lygio skaičiavimų algoritmas.
Geometrinių iškraipymų (distorsijos) parametrams nėra sakičiavimų, kadangi jos įvedamos iš specifikacijos reikalavimų.

PASTABA: Būtina atkreipti dėmesį į darbo katalogo, duomenų ir normų paskirtį - ar panaudojamos pradinio gamybinio proceso valdymui skirtos ar galutinei kontrolei skirtos asimetrijų ir nesuvesties normos bei skaičiuojami defektingumai.

Darbo režimai Duomenų Bazės (DB) sudėtis

Darbo režimai Meniu sistema

Darbo režimai EOP Asimetrijos.

Darbo režimai Asimetrijų optimalios normos


Paklaidų įvertinimas

Darbo režimų koregavimas

Darbo režimų meniu komplekte yra punktas Progr. darbo rėž. parametrai. Čia randasi forma, leidžianti keisti įvairiausius programos procedūrų algoritmus.

Formoje randasi komandiniai mygtukai procedūroms ir pasirenkami lapeliai atskirų parametrų koregavimui.

Komandiniai mygtukai:

Importas. Atlieka duomenų importą iš tekstinio failo param.sys į DB

Eksportas. Atlieka duomenų eksportą iš DB į tekstinį failą param.sys

Perskaityti iš DB. Iš naujo perskaito parametrus iš DB į formą ir tokiu būdu atstato pakeistus formoje parametrus.

Užrašyti į DB. Pakeistus formoje parametrus užrašo į DB, kad juos išsaugoti ir panaudoti įvairiose kitose procedūrose.

Pasirenkami lapeliai:

Redagavimas. Nustato ar galima redaguoti įvairių rūšių nesusivesties lemnteles su gamybiniais objektais ir ktas duomenų lenteles. Jei čia nėra uždėto paukščiuko, programa neleidžia keisti duomenų.

Nuoseklumas. Nustato ar galima importuoti senesnius pradinius duomenis nei esančius DB. Tai yra reikalavimas, kad pradiniai duomenys būtų surašyti griežtai nuosekliai laiko atžvilgiu. Programa senesnių duomenų neima, nei paskutinių duomenų laikas.

Ta pati data. Nustato ar galima importuoti tos pačios datos vienodų gam.objektų komplekto pradinius duomenis. Kiekviena KS būna pagaminta su įvairiu įrengimų ir jų rūšių komplektu, kurių variantų masinėje gamyboje gali būti labai daug. Siekiant, kad duomenys atstovautų vienodai įvairius įrengimus, galima panaudoti tokį filtrą. Jeigu duomenys iš tų pačių įrengimų ir juos būtina skaičiuoti, tai reikia nuimti paukščiuką.

Vienodi obj. Nustato kiek paskutinių importuotų įrašų tikrinti ar ne vienodi gam.objektų komplektai su paskutine data.

Proc. tikrinimas. Nustato ar NEtikrinti, kad visų gam.objektų įrašų laukai IV būtų vienodo skaičiaus. Tie patys pradiniai ar tarpiniai duomenys gali būti panaudoti daug kartų skaičiuojant įvairių rūšių parametrus. Programa duomenų panaudojimo skaičių išsaugo šiame lentelių IV lauke. Jei tas skaičius nevienodas, tai galimas daiktas įvyko klaida ar gedimas. Tuomet šių duomenų nereikia panaudoti statistikoje. Jei netikrinti, tai reikia uždėti paukščiuką.

Gam.Obj.sk. Nustato kokiam lauko IV ciklo kiekiui esant skaičiuoti gam.obj.parametrus (arba visada skaičiuoti, jei čia nustatytas 0).

Šalinimas. Nustato ar galima šalinti pradinius, asimetrijų, kontr. surinkimų ir gamybos objektų duomenis iš atitinkamų DB lentelių.

Išskirt.obj. Nustato keliems išskirtinių objektų komplektams gali būti vertinami vienos KS duomenys, kad nereikėtų be reikalo ieškoti jų DB lentelėje.

Gam.Obj.Tipai. Nustatomi gamybos objektų tipai, kuriems atliekami skaičiavimai. Programoje numatyti šie tipai: BEN - bendrieji rezultatai, kai skaičiuojama statistika nepriklausomai nuo gamybos objekto; ENR - eilučių ritelių nr.(3 skaičiai); KNR - kadrų ritelių nr.(4 skaičiai); KOR - korpuso nr.(4 skaičiai); LAI - panaudojamo laido tiekėjas(3 raidės); FER - panaudojamo ferito tiekėjas(3 raidės); KIN - kineskopo nr.(9 skaičiai); JUS - pagamintos KS derintojo nr.(3 skaičiai); KON - kontrolieriaus nr.(4 skaičiai); BAR baro nr.(3 skaičiai)- ; PAV operatoriaus pavardė(10 raidžių)- ; ENK - eilučių ritelių kompleksinis nr.(3 skaičiai)(susidedantis iš skirtingų nr. pavyzdžiui įvairiose pamainose, bet KS pagamintose tose pačiose staklėse); KNK - kadrų ritelių staklių nr.(4 skaičiai)(susidedantis iš skirtingų nr. pavyzdžiui įvairiose staklių laikikliuose); KNA - kadrų ritelių aukšto nr.(4 skaičiai); KNS - kadrų ritelių stovo nr.(4 skaičiai); MAP - matavimo priemonių tipas; SUN - šuntų panaudojimo operacija(3 raidės).

Statist.tipai. Užkoduoti statistikos ir asimetrijų parametrai, kuriems atliekami skaičiavimai. NES - pirminiai elektroniniai-optiniai parametrai; ASI - astigmatizmo ir komos nesusivestis; AST - astigmatizmo asimetrijos; KOM - komos asimetrijos; DIS - distorsijos (geometrinių iškraipymų) asimetrijos; S0 - pagrindinės ekrano zonos; S1 - tarpinės ekrano zonos viršuje ir apačioje; S2 - tarpinės ekrano zonos viduje; S3 - tarpinės ekrano zonos kairėle ir dešinėje; X - vidurkiai; Z - išsibarstymai; C - proceso tinkamumo koeficientai (Cpk); B - defektingumas (%); 1 - minimali imtis; 2 - vidutinė imtis; 3 - maksimali imtis.

Import.data. Importuojamų pirminių duomenų datos formatas. Pvz: MM-DD-YYYY , kur MM - mėnuo, DD - diena, YYYY - metai. Laiko formatas nekeičiamai suprantamas hh:mm:ss - valandos, minutės, sekundės.

S0 zonos. Pagrindinių ekrano zonų komplekto adresai. Dažniausiai būna 22;24;26;42;44;46;62;64;66.

S1 zonos. Tarpinių ekrano zonų komplekto adresai viršuje ir apačioje. Dažniausiai būna 23;24;25;42;44;46;63;64;65.

S2 zonos. Tarpinių ekrano zonų komplekto adresai viduje. Dažniausiai būna 33;24;35;42;44;46;53;64;55.

S3 zonos. Tarpinių ekrano zonų komplekto adresai kairėle ir dešinėje. Dažniausiai būna 32;24;36;42;44;46;52;64;56.

Gam.Obj.Atask. Gamybos objekto ataskaitos elektroninės lentelės formos paleidimo komanda. Dažniausiai būna run /n C:\Program Files\Microsoft Office\Office\EXCEL.EXE gamobjp4.xls Būtina įsitikinti ar gerai nurodytas kelias!

Kontrol.Atask. Kontrolės ataskaitos elektroninės lentelės formos paleidimo komanda. Dažniausiai būna run /n C:\Program Files\Microsoft Office\Office\EXCEL.EXE ks5147.xls Būtina įsitikinti ar gerai nurodytas kelias!

Minolt.zonos. Minoltos matavimo etapų minimalus zonų skaičius matavimų pilnumo kontrolei. Jei pirminiuose duomenyse zonų skaičius neatitinka nurodytam skaičiui, tai tuomet jie neimportuojami. Dažniausiai būna pvz: N21G08R03; Tai reiškia, kad nesuvestis matuojama 21 zonose, distorsija ar geometriniai skleistinės iškraipymai matuojami 8 zonose ir ortogonalumas matuojamas 3 zonose.

Pataisos. Ar galima skaičiuoti be pataisų. Šis parametras apsaugo nuo klaidingų duomenų, kai nepanaudojamos pataisos.

Vingelis. "Vingelio"importo DB. Dažniausiai būna PILN.DBC; gali būti ir NES.DBC. Dar papildomai čia, loginio žymeklio pagalba nustatoma, ar pirminiai duomenys su pataisom (kai nereikia jas eliminuoti šioje programoje) ar be pataisų (kai reikia jas eliminuoti PRNEGA programoje).

IPS. Analogiškai.

Kamaya. Analogiškai.

Stefanovič. Analogiškai.

Partijų statist. Loginio žymeklio pagalba nustatoma, ar pradinių duomenų ir KS DB statistiką skaičiuoti atskirai kiekvienam barui - partijai ar visam įvestam duomenų komplektui, neskirianr baro - partijos.

Kontr.sur.imtys. Kontrolinių surinkimų imties max matavimų periodas minutėmis. Kontroliniai surinkimai atliekami periodiškai. Kiekvienam kontroliniam surinkimui skaičiuojami statistikos parametrai. Dėl to, kai importuojamas didelis duomenų kiekis, pagal matavimų laiko skirtumus programa atskiria vieną kontrolinį surinkimą nuo kito. Čia galima keisti šį laiką.

Kontr.sur.Atask. Kontr.sur.ataskaitos formavimo parametrų failas. Pagal nutylėjimą būna KONSURP.SYS . Tai tekstinio tipo failas, kuriame nurodytas parametrų komplektas kontrolinių surinkimų ataskaitai. Jo formavimui skirta speciali procedūra Gamybos kontrolinių surinkimų meniu komplekte - Ataskaitos EOP pasirinkimas. Šiame faile taip pat galima nurodyti ir alternatyvų parametro žyminį, jei kuriam nors užsakovui reikia kitaip, negu naudojama šioje programoje.

Nesusivestis. Pradinių duomenų nesusivesties bet kurios ekrano zonos bet kurių spindulių koordinatinės reikšmės matavimų limito dydis, viršijus kurį teigiama, kad matavimas klaidingas ir jį nereikia importuoti į DB.

Skleistinė. Pradinių duomenų skleistinės (geometrinių) bet kurios ekrano zonos koordinatinės reikšmės matavimų limito dydis, viršijus kurį teigiama, kad matavimas klaidingas ir jį nereikia importuoti į DB.

Balansas. Pradinių duomenų skleistinės balanso matavimų limito dydis, viršijus kurį teigiama, kad matavimas klaidingas ir jį nereikia importuoti į DB.

Komentarai. Ar išvesti komentarus į nurodytą failą (koment.txt). Programos darbo komentarai išvedami į nedidelį programos langą. Pažymėjus čia esantį liginį žymeklį šie komentarai bus išsaugoti nurodytame faile.

44. 44 ekrano zonos įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

42. 42;46 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

24. 24;64 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

22. 22;26;62;66 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

43. 43;45 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

34. 34;54 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

33. 33;35;53;55 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

32. 32;36;52;56 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

23. 23;25;63;65 ekrano zonų įtakos mažinimo svorio koeficientas parametrams Q9 ir Q25.

Pastabų perdavimui per kompiuterinį tinklą ar ką nors analogiško, realizuota galimybė užrašyti tekstinį pranešimą į tekstinį failą, vardu Pastaba.bas kuris turi būti darbinėje direktorijoje. Programos paleidimo metu šios pastabos atsiras komentarų lange.


Minolta.exe valdymas

Minolta.exe programos valdymas

Minolta.exe programa panaudojama duomenų pirminiam nuskaitymui ir įvedimui "Minoltos" matuoklio pagalba.

Matuoklis su kompiuteriu jungiamas kabeliu, kurio jungčių kontaktai sujungti sekančiai:

Matuoklio kont. | Komp. 25 kont. | Komp. 9 kont.
1 | 1 | nejungiamas
2 | 3 | 2
3 | 2 | 3
4 | 5 | 8
5 | 4 | 7
6 | 20 | 4
7 | 7 | 5
20 | 6 | 6

Kabelis jungiamas prie jungties COM1 arba COM2. Šias jungtis ir kuri iš jų COM1 ar COM2 gali būti patikrinta kompiuterio pelės ir atitinkamos programos pagalba. Kadangi Minolta.exe programa naudojama DOS -inėje aplinkoje, gali būti panaudota pavyzdžiui dmouse.com programa. Prijungus pelę prie kurios nors jungties, surenkama komanda dmouse /c1 , jei norime konfiguruoti pelę COM1 jungčiai, arba dmouse /c2 - jei COM2 jungčiai. Po to žiūrime ar veikia pelė. Tokiu būdu gali būti nustatyta kuri jungtis COM1, kuri COM2 ir ar jos veikia. Tuomet prie tos jungties jungiamas aukščiau nurodytas minoltos kabelis. Jei norime pelę atjungti ir iškrauti iš atminties programą, surenkama komanda dmouse /q.

Kokiu režimu dirbs Minolta.exe programa yra nustatoma ar koreguojama minolta.sys faile. Tai tekstinis failas ir jį galima redaguoti tekstiniu redaktoriumi.

Pirmoji šio failo eilutė skirta matuoklio markės nurodymui: MINOLTA CC-100 arba MINOLTA CC-110. Antroji eilutė skirta ryšio kanalo jungties ir režimų nurodymui: COM1:9600,E,7,2,DS,CD. Trečia - devinta eilutės skirtos nesuvesties masyvo adreso nurodymui kompiuterio ekrane, padidintu režimu, kad gerai matytusi iš toliau. Zonų masyvo numeracija nurodyta tekstiniame faile ZONOS.TXT arba šiame helpo puslapyje. Dešimtoji eilutė skirta nesuvesties skirtumo nurodymui, jei nesuvesties zonų matavimai kartojami ir turi būti patikrinti ar nepasikeitė, o taip pat nurodymui, ar kelis kartus matuojant tą pačią zoną, reikia matavimo rezultatus vidurkinti - tuomet po kablelio nurodomas žodis VID. Vienuoliktoji eilutė skirta programos įvairių ciklų dydžio nurodymui. Pirmasis skaičius - nesuvesties matavimų paruošiamajam ciklui, antrasis skaičius nesuvesties matavimo zonų ciklui, trečiasis skaičius - išėjimui iš matavimų ciklo nulinių matavimo rezultatų skaičiui, ketvirtasis skaičius - geometrinių iškraipymų matavimo paruošiamajam ciklui, penktasis skaičius - geometrinių skleistinės iškraipymo zonų ciklui, šeštasis skaičius - ortogonalumo matavimo paruošiamajam ciklui, septintasis skaičius - ortogonalumo matavimo zonų ciklui. Sekančios eilutės skirtos nesuvesties, geometrijos ir ortogonalumo zonų masyvo adresų eiliškumo nurodymui. Šie duomenys yra talpinami į masyvą, turintį septynias eilutes ir septynis stulpelius. Pavyzdžiui produktui DY-70 nesuvesties matavimai atliekami sekančiu nuoseklumu: 44, 64, 24, 42, 46, 43, 45, 25, 26, 36, 35, 56, 55, 66, 65, 63, 62, 52, 53, 32, 33, 22, 23. Jeigu matavimų ciklo skaičius nurodytas didesnis negu nurodytų zonų skaičius, tai zonų adresai imami iš zonų eilės pradžios. Pradžioje su pirmąją N raide nurodomi nesuvesties zonų adresai, po to su G raide geometrinių iškraipymų matavimo zonų adresai ir gale su R raide nurodomi ortogonalumo matavimo zonų adresai.

Jei reikia kad būtų tikrinami ar teisingai rankiniu būdu įvedami gamybos objektų kodai, paskutinės minolta.sys failo eilutės skirtos galimų gamybos objektų kodų variantų nurodymui. Pavyzdžiui ENR=1,2,3 nurodo galimus eilučių įspraustinių kodus. KNR=... kadrų ritelių laikiklių kodus, JUS=... derintojų kodus, KIN=... kineskopų kodus, BAR=... gamybinio baro kodus, PAV=... operatoriaus pavardžių ar inicialų kodus.

Prieš pradedant darbą su minoltos matuokliu, patikrinkite ar kompiuteris turi Turbo klavišą, kuris turi būti įjungtas.

Paleidus MINOLTA.EXE programą darbas gali būti nutrauktas paprasčiausiai nieko neįvedus klaviatūros pagalba ir nuspaudus klavišą Enter. Darbas su šia programa atliekamas keliais etapais. Įvedus bent vieną raidę ar pavyzdžiui duomenų paskirties komentarą, atliekamas perėjimas į pirmąjį paruošiamųjų matavimų etapą, kurio metu atliekamas suvedimas centre, balansas, kiti veiksmai ir matavimų rezultatus nereikia rašyti į kompiuterį. Užbaigus pirmojo etapo veiksmus, išėjimas iš jo gali būti atliekamas du kartus nuspaudus matuoklio videokameros mygtuką, kai ji nukreipta į šalį ir gaunami nuliniai matavimų rezultatai. Tuo pačiu atliekamas perėjimas į antrąjį etapą, kai į kompiuterio ekraną išvedami dideli nesuvesties zonų masyvo adresai ir atliekami matavimai šiose zonose. Esant blogiems matavimų rezultatams, kai gaunami nuliniai rezultatai (rezultatai analizuojami tūkstantųjų mm dalių tikslumu), zonos adresas kartojamas pakartotinam matavimui. Norint išmatuoti nesuvestį kokioje nors kitoje zonoje, įsiterpiant į zonų eiliškumą, nurodytą MINOLTA.SYS faile, reikia nuspausti Z klavišą (atitikmuo žodžiui zona). Tuomet programa sekančiai zonai paprašys įvesti jos adresą. Nuspaudus A klavišą (atitikmuo žodžiui atgal), sekančios zonos adresas toks, koks buvo prieš tai. Esant dažniems matavimų sutrikimams, kai gaunami nuliniai matavimų rezultatai, jeigu tai kelis kartus paeiliui pasikartoja, susiformuoja analogiškas signalas, kaip kelis kartus nuspaudus minoltos nukreiptos į šalį videokameros mygtuką. Tuomet programos algoritmas pereina į kitą matavimų etapą. Norint šito išvengti, reikia nuspausti nulinį kompiuterio klaviatūros klavišą.
Užbaigus antrąjį etapą, automatiškai atliekamas perėjimas į trečiąjį geometrinių iškraipymų paruošiamųjų matavimų etapą. Toliau seka ketvirtasis - geometrinių iškraipymų matavimo, penktasis - ortogonalumo paruošiamasis ir šeštasis - ortogonalumo matavimo etapai.
Visuose šešiuose etapuose C klavišo nuspaudimas iššaukia išėjimą iš matavimų etapo ciklo, perėjimą į sekantį ar pirmąjį etapą. Užbaigus šeštąjį etapą, atliekamas automatinis perėjimas į septintąjį, gamybinių objektų žyminių įvedimo etapą, po kurio programa kartojama iš naujo.
Įvykus nenumatytiems trikdžiams, beisiko programa gali būti nutraukta Ctrl-Break ar Ctrl-C ir Enter klavišų pagalba. Jei tai įvyko atliekant vieną iš aukščiau išvardytų septynių ciklų, nebūtina visus matavimus pradėti iš naujo, nuo pirmo ciklo. Atitinkamai atsakius į programos pradžioje duodamus klausimus, galima tęsti matavimus pradedant nuo to ciklo, kuriame įvyko trikdis. Patartina laikytis ciklų eiliškumo tvarkos, nes gamybos objektų žyminiai yra paskutiniajame cikle ir pagal juos gamybos analizės programų kompleksas atlieka matavimo duomenų priskyrimą atitinkamiems gamybos objektams ir atlieka reikalingus skaičiavimus.
Esant blogam matuoklio ir kompiuterio sujungimui ar blogai nurodytam kompiuterio jungties adresui MINOLTA.SYS faile, kompiuterio ekrane atsiranda didelis užrašas NEPRIJUNGTA! Jei kompiuteris nenustatytas turbo režime, ar kokie tai parametrai neatitinka, kompiuterio ekrane atsiranda didelis užrašas KLAIDA! ! !
Siekiant realizuoti platesnes panaudojimo galimybes, pačioje šios programos darbo pradžioje yra galimybė pasirinkti atskirą matavimų ciklo etapą bei rankinio, neautomatizuoto duomenų įvedimo režimą.
Programa MINOLTA.EXE matavimų rezultatus išsaugoja NEK.MIN tekstiniame faile. Tekstinio redaktoriaus pagalba šiame faile galima rasti siunčiamas komandas bei matuoklio atsakymus, skirtus ryšio seansui, arba klaidų kodus ir toliau matavimų rezultatus. Eilutės pradžioje nurodyta matavimo etapo atitinkama raidė (N,G ar R), atitinkamas matavimo zonų masyvo adresas, po kurio seka matavimo rezultatai šioje zonoje.

Darbo režimai Matavimo zonos ir duomenų išdėstymas.


Duomenų importas

Pirminių KS duomenų importas

Iš galimų KS duomenų įvedimo būdų paprastai panaudojamas duomenų importas.

KS duomenų importas atliekamas iš atitinkamo matavimo įrenginiui priklausančio kompiuterio ar serverio, pasinaudojant bendrovės kompiuteriniu tinklu ar atneštomis iš ten duomenų kopijomis.

Kiekvienas matavimo įrenginio tipas formuoja skirtingus duomenų failo tipus su atitinkamais vardų plėtiniais.

Labai svarbu, kad importuojami duomenys butų be klaidų ir turėtų panaudotų gamybos objektų žyminius. Jeigu pavyzdžiui kineskopo žymuo nenurodytas, o failo pavadinime yra matavimo įrenginio numeris, tai prieš atliekant importą būtina redaguoti duomenų failą ir įterpti numerį į kineskopo vietą.

Paleidus atitinkamą importo programą ar jos procedūrą, paprastai atveriama programos duomenų failo pasirinkimo forma, kurioje nurodomas konkretus pavadinimas. Šioje formoje galima taip pat pasirinkti ne tik darbinį, bet ir įvairius kitus katalogus arba net kitus kompiuterius ar serverius. Programa prieš duomenų paėmimą patikrina pradinę duomenų failo struktūrą.

Vingelio , Kamajos , Minoltos , Stefanovičiaus vdt ir IPS matuokliams pradinių duomenų meniu komplekte yra prad.duomenų rinkinio formavimo procedūra. Joje galima suformuoti rinkinį iš daugelio duomenų failų, pavyzdžiui esant poreikiui paskaičiuoti statistiką ilgesniam laiko periodui, bei atlikti duomenų rondomizaciją (duomenų atsitiktinę atranką), kai skaičiavimai turi būti atlikti skubiai. Yra galimybė į rinkinį įtraukti ne tik atskirus duomenų failus, bet ir visus pasirinkto matavimo įrenginio tipo duomenų failus, nurodant direktorijas. Taip pat yra galimybė surikiuoti duomenų failų sąrašą pagal failo pavadinimą. Procedūros pabaigoje dar yra galimybė peržiūrėti rinkinio sudėtį ir jį redaguoti. Rinkinio sąraše atsispindi kiekvieno duomenų failo dydis ir formavimo pradžios data bei laikas.

Atitinkamo matavimo įrenginio i mporto procedūra pradžioje paklausia, ar bus pasirenkamas atskiras duomenų failas, ar duomenų rinkinys.

Norint, kad importas iš rinkinio būtų atliekamas nuosekliai iš atitinkamai surikiuotų failų (pvz. surikiuotų pagal laiką ar kitaip), suformuotas failų rinkinys gali būti dar perrikiuotas Excelio pagalba atlikus eksporto importo procedūrą DB failui Dfkompl.dbf

Importo procedūros eigoje duomenys sudedami į pirminių duomenų bazės atitinkamų lentelių atitinkamus laukus. Kompiuteriniai PRNEGA programos pirm.duomenų kineskopo ekrano vietos adresai nurodyti Darbo režimai Duomenų struktūroje.

Pastaba: Kadangi dar panaudojami seno tipo kompiuteriai, tai Windows sistemą reikia suderinti dešimtainio skaičiaus atvaizdavimui su tašku, o ne kableliu.


skaičiavimai

Skaičiavimų atlikimas

Į suformuotą DB įvedus matavimų duomenis yra atliekami skaičiavimai.

Kiekviename iš pirmųjų keturių iš kairės meniu komplektų yra atitinkami pasirenkamų skaičiavimų punktai. Jų atlikimo tvarkos logika gali būti suvokta pagal pavadinimą ir atlikta nuosekliai išdėstyta tvarka: meniu komplektai pasirenkami iš kairės į dešinę ir kiekviename iš komplektų pasirenkami meniu punktai iš viršaus į apačią.

Darbo režimai paklaidų įvertinimas

Darbo režimai KS parametrai

Darbo režimai asimetrijų skaičiavimas

Darbo režimai Nesuvesties ir asimetrijų algoritmai

Darbo režimai Optimalių parametrų skaičiavimas

Darbo režimai Gamybos įrengimų parametrų skaičiavimas

Darbo režimai kontrolinių surinkimų skaičiavimas

Darbo režimai gamybinių objektų skaičiavimas

Darbo režimai Skaičiavimai DOS aplinkoje


Paklaidų įvertinimas

Matuojant KS parametrus yra panaudojami kineskopai ir įrenginiai, kurie nėra idealūs ir gaunamos paklaidos. Jei matavimo įrenginys toks, kad neįvertina šias paklaidas, tai jos turi būti įvedamos į pirminių duomenų bazę ir pirminiai matavimų duomenys po importo perskaičiuojami.

Kadangi yra skaičiuojami statistikos parametrai, jiems reikalingi KS parametrų limitai (normos), pataisos (pataisos) ir centrinės nesuvesties perskaičiavimo koeficientai (statikos koeficientai). Šie pradiniai duomenys kiekvieno tipo KS gali būti skirtingi, dėl to įvedami Pirmin. DB lentelių redagavimo meniu punkto pagalba atitinkamose formose arba nukopijuojami iš kitų katalogų arba kompiuterių, kur anksčiau buvo įvesti.


Nesuvesties ir asimetrijų algoritmai
11 | 12 | 13 | 14 | 15 | 16 | 17
21 | 22 | 23 | 24 | 25 | 26 | 27
31 | 32 | 33 | 34 | 35 | 36 | 37
41 | 42 | 43 | 44 | 45 | 46 | 47
51 | 52 | 53 | 54 | 55 | 56 | 57
61 | 62 | 63 | 64 | 65 | 66 | 67
71 | 72 | 73 | 74 | 75 | 76 | 77

Kineskopo ekrano zonos, kuriose matuojamos nesusivesties koordinatės parodytos dešinėje: (paryškintos pagrindinės matavimų zonos, įeinančios į S0 komplektą). Smulkiau žr.

Koordinatės matuojamos nuo centrinio žalio spindulio iki raudono ir mėlyno spindulių pedsakų kineskopo ekrane. Tokiu būdu kiekvienoje zonoje gaunamos 4 koordinačių reikšmės.

 | S0 |  |  | S1 |  |  | S2 |  |  | S3 |
22 | 24 | 26 | 23 | 24 | 25 | 33 | 24 | 35 | 32 | 24 | 36
42 | 44 | 46 | 42 | 44 | 46 | 42 | 44 | 46 | 42 | 44 | 46
62 | 64 | 66 | 63 | 64 | 65 | 53 | 64 | 55 | 52 | 64 | 56

Čia parodyti Zonų komplektai, kuriose analizuojamos asimetrijos (efektai):

Duomenų bazių lentelių pavadinimai suformuoti remiantis sekančių žodžių santrupomis:
Pil – pradiniai matavimų duomenys; nes - n – nesusivesties koordinatės; geo - g – skleistinės geometrijos (distorsijos) iškraipymų koordinatės; obj – gamybos objektų sąrašas; kom – komos asimetrijų duomenys; ast – astigmatizmo asimetrijų duomenys; dis – distorsijos iškraipymų duomenys; a, asi – asimetrijų dydžiai; S0, S1, S2 ir S3 – zonų komplektai; kr - kadrų ritelių ar su jomis susietų parametrų duomenys; er - eilučių ritelių ar su jomis susietų parametrų duomenys; m, d, n ir w - asimetrijų rūšių (efektų) duomenys; s - statistikos duomenys;

Duomenų bazės lentelių laukų pavadinimai suformuoti remiantis sekančiais algoritmais:
n**1 - žalio raudono spindulių nesusivestis x kryptimi (** vietoje - zonos Nr.)
n**2 - žalio mėlyno spindulių nesusivestis x kryptimi
n**3 - žalio raudono spindulių nesusivestis y kryptimi
n**4 - žalio mėlyno spindulių nesusivestis y kryptimi
g**1 - žalio spindulio ir kaukės nesuvestis x kryptimi ar koordinatė x daviklio atžvilgiu
g**3 - žalio spindulio ir kaukės nesuvestis y kryptimi ar koordinatė y daviklio atžvilgiu

ax22=n222-n221;
ay22=n224-n223;
kx22=(n222+n221)/2;
ky22=(n224+n223)/2.
gx22=g221;
gy22=g223;

Nesusivesties asimetrijų koordinatės 22 zonai iš S0 zonų komplekto.
a - astigmatizmui; k - komai, g - skleistinės geometrijai (distorsijai).
Kitoms zonoms nuo 24 iki 66, įeinančioms į S0 zonų komplektą - analogiškai. (laukų pavadinimai lentelėse nuo n221, n222, n223, n224 iki n661, n662, n663, n664 bei nuo g221, g223 iki g661, g663)

x1=ax22; y1=ay22 | x2=ax24; y2=ay24 | x3=ax26; y3=ay26
x4=ax42; y4=ay42 | x5=ax44; y5=ay44 | x6=ax46; y6=ay46
x7=ax62; y7=ya62 | x8=ax64; y8=ay64 | x9=ax66; y9=ay66

Astigmatizmo nesusivesties koordinatės S0 zonų komplektui.DB lentelėje.
Kitiems nuo S1 iki S3 zonų komplektams analogiškai.
Šie parametrai ir astigmatizmui ir komai.
X (horiz.) ir Y (vertik.) koordinatėms:
(laukų pavadinimai lentelėse nuo x1, y1 iki x9, y9)

Atskirai skaičiuojamos nesusivesties koordinatės ir asimetrijos astigmatizmui, komai ir distorsijai.

Asimetrijų
Parametrai S0 zonų komplektui.
Kitiems nuo S1 iki S3 komplektams analogiškai.
(laukų pavadinimai lentelėse nuo p1 iki p40, a - astigmatizmui; k - komai)
ap01=(ax2+ax8)/2; ap03=(ay2+ay8)/2; ap05=(ax2-ax8)/2; ap07=(ay2-ay8)/2;
ap02=(ax4+ax6)/2; ap04=(ay4+ay6)/2; ap06=(ay4-ay6)/2; ap08=(ax4-ax6)/2;
ap10=(ay1-ay3-ay7+ay9)/4; ap12=(ax1-ax3-ax7+ax9)/4;
ap09=(ax1+ax3+ax7+ax9)/4;
ap11=(ay1+ay3+ay7+ay9)/4;
ap13=(ax1+ax3-ax7-ax9)/4;
ap15=(ay1+ay3-ay7-ay9)/4;
ap14=(ay1-ay3+ay7-ay9)/4;
ap16=(ax1-ax3+ax7-ax9)/4;
ap23=0.2*(4*ap16+3*ap15);
ap24=0.2*(4*ap16-3*ap15);
ap22=0.2*(4*ap13-3*ap14); ap21=0.2*(4*ap13+3*ap14);
ap19=0.2*(4*ap12+3*ap11);
ap20=0.2*(4*ap12-3*ap11);
ap17=0.2*(4*ap09+3*ap10);
ap18=0.2*(4*ap09-3*ap10);
ap25=ap09-ap01; ap26=ap09-ap02;
ap27=ap11-ap03; ap28=ap11-ap04;
ap29=ap13-ap05; ap30=ap14-ap06;
ap31=ap15-ap07; ap32=ap16-ap08;
ap33=-ap01+ap02-ap10;
ap34=-ap01-ap02+ap09;
ap35=-ap03+ap04-ap12;
ap36=-ap03-ap04+ap11;
ap37=0; ap38=0; ap39=0; ap40=0.

kp07 =(kx2+kx8)/2; kp05
=(ky2+ky8)/2; kp03 =(kx2-kx8)/2; kp01 =(ky2-ky8)/2;
kp08 =(kx4+kx6)/2; kp06
=(ky4+ky6)/2; kp04 =(ky4-ky6)/2; kp02 =(kx4-kx6)/2;
kp16 =(ky1-ky3-ky7+ky9)/4; kp14
=(kx1-kx3-kx7+kx9)/4;
kp15 =(kx1+kx3+kx7+kx9)/4; kp13
=(ky1+ky3+ky7+ky9)/4;
kp11 =(kx1+kx3-kx7-kx9)/4; kp09
=(ky1+ky3-ky7-ky9)/4;
kp12 =(ky1-ky3+ky7-ky9)/4; kp10
=(kx1-kx3+kx7-kx9)/4;
kp23=0.2*(3*kp16+4*kp15);
kp24=0.2*(4*kp15-3*kp16);
kp22=0.2*(4*kp14-3*kp13);
kp21=0.2*(3*kp13+4*kp14);
kp19=0.2*(3*kp12+4*kp11);
kp20=0.2*(4*kp11-3*kp12);
kp17=0.2*(4*kp10+3*kp9); kp18=0.2*(4*kp10-3*kp9);
kp25=kp09-kp01; kp26=kp10-kp02;
kp27=kp11-kp03; kp28=kp12-kp04;
kp29=kp13-kp05; kp30=kp13-kp06;
kp31=kp15-kp07; kp32=kp15-kp08;
kp33=0; kp34=0; kp35=0; kp36=0;
kp37=-kp05+kp06-kp14;
kp38=-kp05-kp06+kp13;
kp39=-kp07+kp08-kp16;
kp40=-kp07-kp08+kp15.

Asimetrijų parametrai kiekvienoje iš trijų aukščiau nurodytų rūšių (ast; kom; dis) išdėstomi (žr. pieš.) ir rūšiuojami bei analizuojami sekančiai:
Asimetrijų parametrai talpinami į lenteles iš 4 eilučių po 8 parametrus eilutėje;
Eilutės skirtos (ekrano zonų grupių dalys):
1 eil. iš 8 parametrų (p1-p8) – asimetrijos par. ant kineskopo ekrano ašių;
2 eil. iš 8 parametrų (p9-p16) - asimetrijos par. kineskopo ekrano kampuose hor., vert. kryptimis;
3 eil. iš 8 parametrų (p17-p24) – asim. par. kin. ekr. kampuose perimetro ir įžambinių kryptimis;
4 ir 5 eil. po 8 param. (p25-p40) – anizotropijos parametrai;
Stulpeliai skirti (asimetrijų grupių dalys):
1 ir 2 stulp. – centrinei asimetrijai ar M efektui;
3 ir 4 stulp. – sukamajai asimetrijai ar D efektui;
5 ir 6 stulp. – vertikaliajai asimetrijai ar N efektui;
7 ir 8 stulp. – horizontaliajai asimetrijai ar W efektui.

NORMOS

Gaminių specifikacijose yra nurodomos nesuvesties normos.
Gamyba yra valdoma asimetrijų parametrų pagalba
Dėl to egzistuoja asimetrijų normų pasirinkimo problema.
Paprasčiausiu atveju asimetrijų normos formuojamos mažesnės negu nesuvesties.
Parametrams ant ašių imamas koeficientas 0.8 , o kampuose koeficientas 0.6 .

Geometrijos (distorsijos) parametrai specifikacijose nurodomi kitaip negu nesuvesties.

Jų P01-P24 ir iki P32 normų skaičiavimo algoritmas
iš H, V, TRh, TRv, PARh, PARv ir ORT specifikacijos parametrų

Pagalvė H = P25 ; *k=P01 ; *k=P05 ; *k=P09 ; *k=P13 ; *k=P06 ; *k=P29 ; *k=P30 ;
Pagalvė V = P26 ; *k=P02 ; *k=P08 ; *k=P10 ; *k=P15 ; *k=P07 ; *k=P31 ; *k=P32 ;
Pagalvė (H+V)/2 ; *k=P17 ; *k=P18 ;

Trapecija TRh = P16 ;
Trapecija TRv = P14 ;
Trap ir Pag (TRh+H)/2 ; *k=P21 ; *k=P22 ;
Trap ir Pag (TRv+V)/2 ; *k=P23 ; *k=P24 ;

Lygiagretainis PARh = P12 ; *k=P28 ;
Lygiagretainis PARv = P11 ; *k=P27 ;
Lygiagretainis (PARh+PARv)/2 ; *k=P19 ; *k=P20 ;

Ortogonalumas ORT = P03 ; P4 = 0

Tiesioginiai P parametrai = ženklo dešinėje be k koef. imami iš specifikacijos tiesiogiai
Likusieji parametrai su ženkleliu k - su mažinančiu specifikacijos.dydį koeficientu
k = 0.75


KS parametrai

Kai yra importuoti pirminiai duomenys ir atliktas paklaidų įvertinimas, atliekamas KS parametrų skaičiavimas. Tai spidulių pėdsako astigmatizmo, komos ir skleistinės iškraipymai zonose S0, S1, S2 ir S3. Paskaičiuojami koordinatiniai atstumai tarp atitinkamų spindulių pėdsakų ir sudedami į atitinkamą DB lentelę.

.

.

.

.


Asimetrijų skaičiavimas

Kai paskaičiuotas KS spindulių pėdsako astigmatizmas, koma ir skleistinė, yra skaičiuojamos šių asimetrijos rūšių asimetrijų efektai.

Darbo režimai EOP Asimetrijos.

Darbo režimai Nesuvesties ir asimetrijų algoritmai


Asimetrijų opt.normos

Asimetrijų optimalios normos

Kai paskaičiuota KS asimetrijų statistika, galima ieškoti optimalias normas. Jos skaičiuojamos atskirai kiekvienai zonai (S0, S1, S2, S3), kiekvienai krypčiai (horizontalia ir vertikalia kryptimis) ir astigmatizmui bei komai.

Programos meniu komplekte yra realizuoti dvi galimybės: paskaičiuoti ar redaguoti normas atskirai kiekvienai zonai, arba paskaičiuoti iškart visoms zonoms.

Skaičiavimų algoritmas remiasi atliktais tyrimais ir realizuojamas trimis būdais, priklausomai nuo defektingumo lygio. Esant nesuvesties defektingumui virš 1% yra aiškiai išreikštas nesuvesties ir asimetrijų defektingumo sutapimo maksimumas, nuo asimetrijų normos. Dėl to yra kopijuojami vėliausiai atliktų matavimų duomenys, jei reikia papildomi sugeneruotomis reikšmėmis iki 10000 KS ir optimizuoja defektingumo sutapimą. Esant nesuvesties defektingumui nuo 0.1 iki 1% randamas sekančių dviejų rūšių KS sutapimas: kai asimetrijos geros o nesuvestis bloga ir kai asimetrijos blogos o nesuvestis gera. Esant dar mažesniam nesuvesties defektingumui yra skaičiuojamas teorinis defektingumas ir ieškomas nesuvesties ir asimetrijų defektingumo sutapimas.

Skaičiavimų ir optimumo paieškos rezultatai rašomi į DB lentelę Asimnorm.dbf ir gali būti eksportuoti į Excelio lentelę.

PASTABA: Čia panaudojamos pradinio gamybinio proceso valdymui o ne galutinei kontrolei skirtos asimetrijų ir nesuvesties normos bei defektingumai.

Darbo režimai Nesuvesties ir asimetrijų normos

Darbo režimai EOP Asimetrijos.


OPTIMALIŲ parametrų skaičiavimas

Optimalūs asimetrijų parametrai skaičiuojami siekiant optimaliai suderinti gamybinius objektus ir patikrinti konstruktyvines paklaidas. Procedūros atliekamos tam skirtame Asim. optimumas meniu komplekte. Įvertinamos ne tik pagrindinės, bet ir kampų tarpinės zonos, imant domėn astigmatizmą, komą ir distorsiją (geometriją). Ašių tarpinės zonos kol kas neįvertinamos.

Duomenų bazė instaliuojama ar duomenys šalinami taip pat kaip pirmuose dviejuose meniu komplektuose.

Po duomenų įvedimo ir skaičiavimų šiuose dviejuose meniu komplektuose, atliekamas gamybos objektų importas, kad galima būtų pasirinkti gamybos objektus. Jie automati6kai pasirenkami meniu punkto Gam.objektų žymėjimas pagalba arba rankiniu būdu naršyklės pagalba, kur lentelės kairėje pusėje pele reikia juodai pažymėti langelius.

Skaičiavimai atliekami meniu punktu Opt. asim. skaičiavimai, kur pradžioje yra galimybė nurodyti ar pasirinkti skaičiavimo parametrus, bet galima palikti ir tuos, kurie jau būna įrašyti į atitinkamus laukelius. Jei anksčiau buvo suformuota ataskaita, tai iš jos automatiškai yra paimami optimumui reikalingi parametrai.Skaičiavimai atliekami remiantis 2003 m pradžioje atliktais statistiniais tyrimais, kai optimizuojami asimetrijų parametrai suskirstyti į aštuonis sluoksnius pagal koreliacinių ryšių matricą. Tai eilučių bei kadrų ritelių asimetrijų parametrai po keturias nesuvesties asimetrijų keturiose ekrano zonose ir skleistinės geometrijos parametrų grupes. Asimetrių sluoksniai logiškai surūšiuoti į centrinę (M efektas), sukamąją (D efektas), vertikalią (N efektas) ir horizontalią (W efektas), taigi ir skaičiavimai atliekami šiems sluoksniams. Kiekvieną iš aštuonių sluoksnių prieš skaičiavimų atlikimą galima papildyti dar keturiom pasirenkamom asimetrijom Opt. naršyklėje Papildomų asimetrijų meniu papunkčio pagalba. Po skaičiavimų ir prieš analizės ir ataskaitos atlikimą galima pašalinti iš kiekvieno sluoksnio bet kurią asimetriją su rezultatų perskaičiavimu.

Norint kad rezultatai būtų tikslesni, skaičiuoti reikia keliais etapais. Visų pirma turi būti parenkama kritinė sluoksnio asimetrija (tikslo parametras iš analizės rezultatų). Antra kadangi rūšiavimas ir skirstymas į nurodytą kiekį imčių atliekamas pagal tikslo parametro dydį, šių imčių išsibarstymus (std) reikia pakoreguoti. Jie turi būti didesni už rūšiavimo būdu gautą išsibarstymą ir mažesni už bendrą išsibarstymą ar išsibarstymą gautą pasirinkus kitą tikslo parametrą. Konkretus dydis nustatomas optimumo skaičiavimams pasirinkus kitą tikslo parametrą. Formoje įvestas koeficientas padidina tikslo išsibarstymą nurodyta formoje dalimi nuo išsibarstymų skirtumo ir sumažina likusių asimetrijų išsibarstymą nurodyta formoje dalimi nuo išsibarstymo ketvirčio.

Rezultatus galima pasižiūrėti naršyklėje (su nekoreguotais išsibarstymais), arba eksportuoti į Excelio lentelės šabloną, kuriame koreguoti rezultatai atvaizduojami grafiškai. Čia yra asimetrijų grupės parametrų sudėties grafikas ir tos grupės gamybinių objektų grafikai. Parametrų sudėties grafiko pagalba labai paprasta nustatyti kritinius parametrus, kuriems reikia skirti didesnį dėmesį. Gamybos objektų grafikai gali parodyti kritinius objektus, dėl kurių gaunasi blogesnė kokybė.

Yra galimybė pasirinkti vieną gamybinį objektą (filtruoti duomenis vienam gamybiniam objektui), skaičiuoti jam optimalias asimetrijas ir gauti gaminio surinkimo su kitais gamybiniais objektais rezultatus, t.y. kokie gaunasi skirtumai įvairiems surinkimo variantams.

Pabaigoje galima išanalizuoti optimumų skaičiavimo rezultatus ir užrašyti į Excelio lentelę išvadas meniu punkto Optimumų analizė pagalba. Čia pateikiamos kritinės asimetrijos, optimumų reikšmės ir kritiniai gamybiniai objektai, kuriems defektingumas didžiausias.

Šiame meniu komplekte dar galima paskaičiuoti ir išvesti į Excelio lentelę Gamybos objektų komplektacijos variantų realizacijų skaičius. T.y. su kokiais gamybos objektų komplektais kiek surinkta gaminių. Tokiu būdu galima patikrinti ar atsitiktinai gaminiuose pasiskirstę įrengimai, su kuriais pagaminti gaminiai.

Meniu punkto XLS grafikai pagalba Excelyje formuojama grafinė priemonė optimalių parametrų ir gamybos objektų vaizdinei apžiūrai.

Optimalių parametrų analizė

Optimalių parametrų grafikai


Gamybos Įrengimų parametrų skaičiavimas

Gamybos Įrengimų (staklių) parametrai skaičiuojami siekiant atlikti įrengimų ir nesuvesties asimetrijų TYRIMUS. Procedūros atliekamos tam skirtame Gamyb. įreng. param. meniu komplekte.

Atliekant procedūrą pirmą kartą pradžioje į darbinę direktoriją reikia instaliuoti pirmųjų dviejų meniu komplektų duomenų bazes ir nukopijuoti duomenų bazę su lentele Stakpar.dbf, ...cdx, ...dbc, ...dcx, ...dct.

Likusios duomenų bazės lentelės ir jų papildymai instaliuojasi automatiškai ir duomenys šalinami taip pat kaip pirmuose dviejuose meniu komplektuose arba pasirinktinai pagal pasirinktą meniu punktą.

Atliekant procedūras ne pirmą kartą, o norint tik papildyti naujais duomenimis ir skaičiavimais, atliekamas Gam.įrengimų parametrų lentelės papildymas naujais duomenimis Gam.įreng.duomenų papildymas meniu punkto pagalba. Prieš tai nebūtina, bet galima patikrinti ir pakoreguoti šių IMPORTO duomenų datos ir laiko nuoseklumą, jei šis nuoseklumas yra svarbus (meniu punktas Gam.įreng.datos ir laiko tikrinimas). Taip pat Gam.įreng.datos su 23val taisymas meniu punkto pagalba galima ieškoti ir taisyti 23 val datos klaidas. Šios klaidos pasitaiko kai trečioje pamainoje įvedami duomenys po 24 val, kai pasikeitė data, o kontroliniai surinkimai buvo atlikti prieš 24 val, kai data dar nebuvo pasikeitusi. Kai operatorius užmiršta pakoreguoti datą, įvertinant paros laiką.

Toliau atliekamas duomenų rinkinio formavimas pirmajame meniu komplekte ir nesuvesties pirminių duomenų importas Gamybos įreng.Kamayos nes.importo meniu punkto pagalba, iškviečiant tam skirtą formą ir joje pasirinkus duomenų atrankos laiko periodo tikslumą. Panaudojami tik tie duomenys, kuriems nurodytu tikslumu sutampa laikas staklių parametrų ir nesuvesties asimetrijų lentelėse.

Rastų asimetrijų įrašų numeriai surašomi į staklių lentelę ir pašalinami šalinimo žymenys kuriems rastos asimetrijos. Tokiu būdu galima pašalinti nereikalingus staklių įrašus arba suformuoti ataskaitą apie bendrą duomenų kiekį bei darbuotojų sėkmingai užregistruotų duomenų kiekį.

Esant aukščiau nurodytai informacijai, galima paskaičiuoti staklių parametrų ir asimetrijų skirtumus. Šie skirtumai parodo pasikeitimus laiko bėgyje, atliekant staklių reguliavimus. Jie skaičiuojami įvertinant eilučių ir kadrų staklių darbo vietų numeraciją bei datą su laiku (taip surikiuoti). Skirtumai skaičiuojami tik vienodiems eilučių ir kadrų numerių komplektams. Šie duomenys ypač reikalingi esant duomenų trūkumui, nes absoliutinius parametrų didumus galima panaudoti tik nagrinėjant atskirus komplektus, o pastariesiems yra daug mažiau duomenų.

Kadangi skirtumai skaičiuojami atskirai kiekvienam eilučių ir kadrų staklių numeriui, tai laukuose Laidaskito, Įspr_valyta ir Stakl_reg yra nurodomas ne tik pradinio ir galutinio įrašų reikšmės, bet ir kiek kartų šis laukas keitėsi eilučių įspraustinei nurodytu laikotarpiu (Data, Laikas, Laikskirt).

Tokiu būdu galima tyrinėti pasikeitimų sąsajas įvairiems parametrams - ir staklių, ir asimetrijų. Duomenų panaudojimo palengvinimui realizuotas jų perrašymas į bendras asimetrijų lenteles bei eksportas į Excelio lenteles.

Viršutiniuose meniu punktuose randasi duomenų apžvalgai skirtos naršyklės, o apatiniuose duomenų šalinimo įvairios procedūros.


Kontrolinių surinkimų skaičiavimas

Kontrolinių surinkimų parametrų skaičiavimas

Kontroliniai surinkimai - tai pirminiam derinimui skirti surinkimai ir matavimai.

Skaičiavimai atliekami po KS parametrų ir asimetrijų skaičiavimų.

Pirmiau suformuojamos ir užregistruojamos kontrolinių surinkimų imtys, kadangi skirtingiems gamybiniams objektams gali būti skirtingi imčių dydžiai. Kai kurių gamybinių objektų imtys (pvz kadrų staklių) gali būti suformuotos iš kitų objektų mažesnių imčių (pvz eilučių staklių). Po to paledžiama skaičiavimų procedūra.

Skaičiuojami visi asimetrijų parametrai nepriklausomai nuo gamybinio objekto tipo.

Yra speciali kompiuterinė forma parametrų peržiūrai.

Prieš ataskaitos formavimą reikia pasirinkti asimetrijų parametrus bei kontrolinių surinkimų imčių kiekį, kuriems formuojami grafikai.


Gamybinių objektų skaičiavimas

Gamybinių objektų parametrų skaičiavimas

Gamybinių objektų EOP, asimetrijų, statistikos ir dinamikos parametrų skaičiavimai užtrunka gana ilgai, kadangi atliekami kiekvienai KS visiems gamybiniams objektams ir kiekvienai dinamikos imčiai.

Prieš tai turi būti įvesti visų objektų tipų dinamikos imčių dydžiai bei nurodyta kompleksinių ar išskirtinių objektų sudėtis.

Rezultatus kiekvienam gamybiniam objektui galima pasižiūrėti atitinkamoje naršyklėje arba suformuoti ataskaitą.

.


Skaičiavimai DOS aplinkoje

Kadangi pirminiam duomenų nuskaitymui dažnai naudojami senesni kompiuteriai, kurie dirba DOS aplinkoje, pirminiam duomenų nuskaitymui ir apdorojimui panaudojamos senesnės DOS-inės programos: nuskaitymui panaudojama Minolta.exe programa, o apdorojimui Neskiv.exe ir Neskata.exe programos.

NESKIV.EXE programa turi kelis pradinio meniu punktus: DUOMENYS, IMPORTAS ir PAKLAIDOS. Pasirinkus IMPORTO meniu punktą, į kontrolės duomenų bazę importuojami "Minoltos" nesuvesties duomenų komplektai (iš NEK.MIN), tik tie, kurie išmatuoti nustatytame matavimo zonų skaičiuje. Tie komplektai gali būti sukomplektuoti iš 9, 13, 23 arba 25 skirtingų zonų, nurodomų MINOLTA.SYS faile. Pagal šį skaičių yra atliekama matavimų komplektiškumo kontrolė. Kartu šio meniu punkto pagalba yra paruošiamas GEO.BAS tekstinis failas, skirtas geometrinių iškraipymų elektroninei lentelei. Jei yra įvestos paklaidos, tai matavimų duomenys šiam failui yra perskaičiuojami su pataisomis. Programa duomenis gali importuoti tik vieną kartą, nes ir į šiuos duomenis įrašo, kad duomenys analizuoti.
Pasirinkus pirmąjį meniu punktą iškviečiama duomenų bazės nesuvesties ir gamybinių objektų žyminių įrašų lentelė kiekvienai kreipiamajai sistemai. Į ekraną išvedami tiktai gamybinių objektų žyminiai. Kursoriaus pagalba pasirenkamas reikalingas įrašas redagavimui, arba INS klavišo pagalba pasirenkamas naujos kreipiamosios sistemos duomenų įvedimas, arba DEL klavišo pagalba pasirenkamas nurodymas šalinti įrašą. Kai nėra įvestų duomenų, iš pirminio DUOMENŲ meniu programa automatiškai pereina į naujų duomenų įvedimą. Duomenų įvedimas pradedamas nuo gamybos objektų žyminių įvedimo formos. Suvedus visus duomenis į šią formą, programa pateikia nesuvesties duomenų įvedimo meniu, pritaikytą duomenų įvedimui įvairiuose zonų komplektuose. Pasirinkus zonų komplektą, programa pateikia atitinkamą nesuvesties įvedimo formą, kur rankiniu būdu gali būti įvedama ar redaguojama nesuvestis. Norint peršokti į įvedimo formos pabaigą ir užrašyti duomenis duomenų bazėje, pakanka nuspausti Ctrl-Enter, norint peršokti į įvedimo formos pradžią ir išeiti iš duomenų įvedimo formos, pakanka nuspausti Ctrl-Esc klavišus.
Analogiškai rankiniu būdu įvedami nesuvesties ir geometrinių skleistinės iškraipymų pataisų bei statinių centr.nesuvesties koeficientų duomenys PATAISOS meniu pagalba. Įvedimo formos "komentarų" lauko pirmieji penki simboliai turi būti įvesti iš žodžių STATInės korekcijos koeficientai, GOMETrijos ar Nesuvesties pataisos su produkto žyminiu, prasidedančiu raidėmis DY ar KS ir kineskopo ar šablono numerio nurodymu, pagal kuriuos kompiuterinės programos, ir operatorius atskiria pataisų bei produkto rūšį ir aparatūros komplektą. Pataisų nustatymo ir įvedimo į duomenų bazes tvarka reglamentuojama technologinio proceso ar matavimo įrenginių dokumentacijoje.

Kokybės ataskaitos nesuvesties duomenų skaičiavimai ir duomenų patikrinimas atliekami pasirinkus atitinkamus NESKATA.EXE programos pradinio meniu punktus. Atliekant patikrinimą reikia nurodyti standartinio išsibarstymo koeficientą, kuris rekomenduojamas 3,5. Programa suranda nesuvesties dydį, viršijantį užduotą išsibarstymą, nurodo jį bei vidurkį su išsibarstymu ir pasiūlo ištaisyti. Reikia patikrinti įvestos nesuvesties ženklą bei dydį ir ištaisyti. Priešingu atveju pasitarus su valdančiu gamybos procesą kokybės inžinieriumi, pašalinti visą įrašą.
Toliau naudojamas NESKATA programos pagrindinio meniu ATASKAITŲ punktas. Jį pasirinkus, į ekraną išvedamas ataskaitų meniu, su NESUVESTIES MATAVIMO DUOMENŲ IŠVEDIMO, NESUVESTIES STATISTIKOS DUOMENŲ IŠVEDIMO, IŠVEST. PAR. KIEKVIENAI KS IŠVEDIMO, IŠVEST. PAR. STATISTIKOS DUOMENŲ IŠVEDIMO, STATISTIKOS DUOMENŲ EKSPORTAS EL. LENT. ir REDAGAVIMO meniu punktais. Pasirinkus vieną iš pirmųjų keturių punktų papildomoje formoje reikia nurodyti išvedamų duomenų failo pavadinimą su išplėtimu. Pageidautinas išplėtimas CLA. Po to būtina REDAGAVIMO meniu punkto pagalba iškviesti CLARIONO redaktorių, kurio pagalba išvesti duomenys papildomi komentarais. Papildytas failas išsaugojamas nuspaudus Ctrl-Enter klavišų pagalba.
Kokybės ataskaitos paruošimui pasirenkamas STATISTIKOS DUOMENŲ EKSPORTAS EL. LENT., kurio pagalba suformuojamas PILN.BAS failas, pritaikytas atitinkamoms QUATTRO ir EXCEL elektroninėms lentelėms. Išėjimas iš clariono programų, meniu, lentelių ar ekrano formų ir jų elementų atliekamas Esc klavišo pagalba.
Programos NESKIV.EXE ir NESKATA.EXE nesuvesties ir skaičiavimų rezultatų duomenų bazes išsaugo atitinkamuose failuose: NEK ir NESK su išplėtimais .DAT ir .K01.

Kreipiamųjų sistemų geometrinių iškraipymų duomenų apdorojimas DOS aplinkoje gali būti atliekamas pvz. DY70G.WQ1 elektroninėje lentelėje, aukščiau minėto GEO.BAS failo ir elektroninės lentelės programų komplekso pagalba. Duomenys importuojami automatiškai iš GEO.bas failo ar įvedami rankiniu būdu į duomenų įvedimo lentelės atitinkamas grafas, o skaičiavimų ir kreipiamųjų sistemų tinkamumo rezultatai yra dešiniau esančioje lentelėje, su * pažymėtais produkto Nr ir parametrais, kurie viršijo užduotas normas. Šioje elektroninėje lentelėje galima keisti tinkamumo ribas ir kineskopo parametrus, derinant programas kitoms kreipiamosioms sistemoms bei keisti statistikos duomenų apimtį naudojantis elektroninės lentelės meniu sistema.
Galutinis kokybės ataskaitos paruošimas DOS aplinkoje gali būti atliekamas DY70.WQ1 (ar atitinkamas kito produkto žymuo) failo pagalba, kurį paleidus Enter klavišo pagalba, pakraunama į operatyvinę atmintį elektroninė lentelė ir importuojami duomenys iš PILN.BAS bei GY70G.WQ1 failų. Įvedami produktų partijos nr., dydžio, datos, atrankos dydžio duomenys ir spausdinami dokumentai. QUATTRO elektroninės lentelės printerio tipo ir spausdinimo ryškumo nustatymas atliekamas pasirinkus sekančius meniu punktus: Options- Hardware- Printers- 1st Printer- Type of printer. Spausdinamos elektroninės lentelės srities nustatymas atliekamas Print- Block meniu su kairiojo viršutinio ir dešiniojo apatinio lentelės kampų nurodymu. Išvedimo režimas pasirenkamas Print- Destination- ir Graphics Print meniu pagalba grafiniam dokumento spausdinimui bei Screen Preview meniu pagalba dokumento patikrinimui ekrane. Spausdinimas ar išvedimas paleidžiamas Print- Spreadsheet Print meniu pagalba. DY70.WQ1 elektroninės lentelės aplinkoje įvykus aukščiau aprašytam automatiniam duomenų importui, šiems duomenims nustatomas duomenų apsaugos režimas. Dėl to gale darbo atlikus šios lentelės išsaugojimą, kitą kartą duomenys negali būti importuojami, nes apsaugoti ir geometrinių iškraipymų elektroninę lentelę reikia pasiimti sekančiu meniu pasirinkimu: File- Open- DY70G.WQ1. Elektroninių lentelių formulės gali būti apsaugotos nuo pakeitimų slaptažodžio pagalba, kurį Informatikos skyrius perduoda žodiniu būdu.
Atskiroms kreipiamųjų sistemų produktų rūšims elektroninių lentelių failus tikslinga pavadinti pagal produkto pavadinimo markę. Su G raide gale pavadinimo geometrinių iškraipymų duomenims ir be šios raidės elektroninei lentelei skirtai kokybės ataskaitos paruošimui (pvz. DY70G.WQ1 ir DY70.WQ1).

Programa NESKATR.EXE skirta duomenų atrankai, perkomplektavimui arba perkėlimui į gamybines duomenų bazes. Jei atranka atliekama į kontrolės duomenų bazę, tai pasirinkti duomenys talpinami į papildomą duomenų bazę NEP.DAT su NEP.K01. NEP duomenų failai gali būti perpavadinti į NEK duomenų failus norint panaudoti atitinkamas programas. Atranką į gamybinę duomenų bazę atlieka gamybos valdymui skirtas kokybės inžinierius atitinkamo meniu pagalba, kuriame yra astigmatizmo, komos, tarpinių zonų astigmatizmo ir komos gamybinių duomenų bazių pasirinkimas SD aplinkai.
Senų gamybos partijų duomenys privalo būti saugojami archyvinio failo pavidale keliose vietose, pavyzdžiui keliuose kompiuterių kietuose diskuose ar disketėse. Archyvinis failas užima kelis kartus mažiau vietos. Minimalaus archyvo paruošimo komanda gali būti sekanti:
PKZIP ARCHYVAS NEK.DAT NEK.MIN
Archyvavimo komanda susideda iš programos pavadinimo, archyvo pavadinimo (kuris gali būti analogiškas katalogo pavadinimui) ir failų sąrašo, kuriuos reikia suarchyvuoti.

Minolta.exe programos valdymas


Analizė

Duomenų analizė atliekama siekiant išsiaiškinti galimus kokybės pagerinimo metodus. Yra nustatomi parametrai, kuriuos reikia pagerinti ir nustatomi gamybiniai objektai, kuriuos reikia paderinti ar atlikti kitokius aptarnavimo ar organizacinius darbus.

Analizės duomenys pasirenkami pagal paskirtį ir rūšį.

  1. Pagal šaltinio vietą gamybiniame procese ir paskirtį, duomenys skirstomi į
  • kontrolinius
  • gamybinių matavimų
  • kontrolinių surinkimų

Paprastai šie duomenys talpinami atskirose direktorijose. Tokiu būdu analizei pasirenkama atitinkama direktorija.

  2. Pagal gamybinio proceso objektų rūšį duomenys skirstomi į
  • KS
  • kontrolinių surinkimų
  • gamybinių objektų

Šie duomenys talpinami skirtingose duomenų bazėse ir pasirenkami atitinkamų menių komplektų pagalba.

  3. Pagal atliktų veiksmų su duomenimis rūšį kiekvienai išmatuotai KS ar paskaičiuotam gamybiniam objektui EOP parametrai PRNEGA programoje yra yra skirstomi į:
  • nesuvesties (koordinatiniai atstumai tarp spalvotų spindulių pėdsakų ekrano zonose) ir skleistinės geometrijos parametrus.
  • asimetrijų parametrus - astigmatizmo, komos ir distorsijos bei poveikio efektų parametrus.
  • zonų komplekto parametrus - S0, S1, S2 ir S3.
  • statistinius parametrus - vidurkiai, išsibarstymai, tinkamumai ir defektingumai bei jų kitimo dinamikos

Šie duomenys talpinami skirtingose DB lentelėse ar atitinkamuose įrašuose ir pasirenkami meniu esančių formų valdymo įrankių pagalba.

Pradžia Duomenų struktūra

Pradžia Duomenų eksportas


Duomenų eksportas ar importas

Duomenų eksportas ar importas atliekamas dažniausiai su tikslu išanalizuoti duomenis su kitomis pagalbinėmis programomis.

Procedurų meniu komplekte yra Duomenu eksporto ar importo procedūros pasirinkimo punktas. Šios procedūros lange randasi sekantys valdymo elementai:

  • eksporto ar importo rūšies pasirinkimas - txt, excel arba dbf;
  • failo pasirinkimo ir eksporto ar importo vykdymo komandų klavišai;
  • pasirinktos lentelės failo vardo ir komentarų langas.

Visų pirma pasirenkam eksporto ar importo rūšį, kuris priklauso kur uždėtas taškas.

Toliau nuspaudžiam pasirinkimo klavišą, dėka kurio atsidaro duomenų bazės lentelių failo pasirinkimo langas. Tai standartinis Windowsų langas, kuriame nurodom failą. Šiame lange nuspaudus pasirinkimo klavišą, jis užsidaro ir procedūros komentarų lange atsiranda pasirinktos lentelės failo pavadinimas.

Pabaigoje su pele nuspaudžiam vykdymo klavišą, procedūra įvykdo nurodymą ir komentarų lange atsiranda siūlymas pasirinkti kitą lentelės failą.

Jei yra vykdomas duomenų importas, programa paklausia ar pašalinti senus įrašus. Atsakius T klavišu, visi įrašai prieš importą pašalinami.

Eksportuotų ar importų duomenų failas randasi toje pačioje direktorijoje kaip ir lentelės failas su tuo pačiu pavadinimu ir pasirinktu išplėtimu. Tiktai eksportuojant ar importuojant į .dbf tipą prie pavadinimo dar prijungiamas + ženklas, kuris parodo kad eksportas atliktas iš lentelės į lentelę, kuri yra nesurišta su kitais duomenų bazės elementais. Nauja lentelė yra senesnio tipo ir daugiau bei įvairesnės pagalbinės programos ją galės panaudoti.

Pastabos:

  • Prieš atliekant importą įsitikinkite, kad importuojamų duomenų failas suformuotas atitinkamos versijos formatu (Microsoft 95 ar 97 versija). Excelio duomenyse neturi būti laukų pavadinimų, kurie atsiranda eksportuojant duomenis iš FoxPro ir kurios reikia pašalinti.
  • Duomenų eksportas į Excelio rinkmeną yra limituotas 16000 įrašų. Norint eksportuoti daugiau, reikia pasirinkti .txt tipo rinkmeną, o po to pakeisti pavadinimą iš .txt į .csv ir pakrauti į Excelį.
  • Direktorijų kelio, kur atliekama procedūra subdirektorijų pavadinimai turi būti suformuoti panaudojant angliškos abėcėlės raides be tarpų, nes tuomet neveikia kai kurios komandos ir programos procedūra gali rodyti klaidas.


Asimetrijų logika

KS sudaro dvi poros kadrų ritelių (kr) ir dvi poros eilučių ritelių (er), kurios išdėstytos simetriškai ir statmenai viena kitai. Televizoriuje tekant pro šias riteles srovei, sukuriamas magnetinis laukas, kuris veikia tris kineskopo elektronų spindulius, skirtus atskiroms spalvoms (b, g ir r – iš žodžių blue, green ir red). Kadrų ritelės kreipia spindulius vertikaliai, eilučių ritelės horizontaliai (y ir x kryptimis). Dėl to ant kineskopo ekrano ašių nagrinėjami parametrai (nuo p01 iki p08) (pvz. priklausantys zonoms 24 ir 64 bei 42 ir 46) priklauso tik nuo er ar kr ir juos lengviau valdyti. Be to kineskopo centre, kur randasi ašys, magnetinis laukas yra mažiau iškreiptas. Tuo tarpu parametrams ekrano kampuose (nuo p09 iki p16 ir nuo p17 iki p24) (pvz. priklausantys zonoms 22, 26, 62 ir 66) daro įtaką ir er ir kr. Be to kampuose magnetinių laukų kreivumas didesnis, dar apsunkinantis jo valdymą technologinio proceso metu. Šioms zonoms yra parametrai, charakterizuojantys asimetrijas x ir y kryptimis (nuo p09 iki p16), o taip pat parametrai, charakterizuojantys iškraipymus radialia ir diogonalia kryptimis (nuo p17 iki p24).

Toliau esantys asimetrijų parametrai (anizotropijos) (nuo p25 iki p32) skirti charakterizuoti asimetrijos skirtumus ant ašių ir kampuose. O gale esantys parametrai (nuo p33 iki p40) skirti charakterizuoti konstruktyvinę ar technologinę specifiką (įdealiu atveju būtų konstantos).

Darbo režimai EOP Asimetrijos.


Asimetrijų rūšiavimas

Asimetrijų parametrai optikos pagrindu skirstomi į astigmatizmo, komos, distorsijos ir impedanso rūšis. Magnetinio lauko technologinio valdymo pagrindu skirstomi į parametrus ant ašių, kampuose, anizotropijos ir specifinius (ar konstruktyvinius). Pagal asimetrijų rūšis skirstomi į centrinės asimetrijos (M), sukamosios asimetrijos (D), vertikalios asimetrijos (N) ir horizontalios asimetrijos (W) rūšis.

Pagal technologinio valdymo lengvumą šias rūšis galima sustatyti į eilę ir sudėti į lenteles pagal rangą:

Astigmatizmas | 1 | Ant ašių | 1 | Horizontali
Koma | 2 | Kampuose | 2 | Vertikali
Distorsija | 3 | Anizotropija | 3 | Sukamoji
Impedansas | 4 | Specifika | 4 | Centrinė

Darbo režimai Asimetrijų logika

Darbo režimai EOP Asimetrijos.


OPTIMALIŲ parametrų analizė

Asimetrijų optimumų skaičiavimo rezultatai analizuojami ir išvados užrašomos į Excelio lentelę meniu punkto Optimumų analizė pagalba. Čia pateikiamos kritinės asimetrijos, optimumų reikšmės ir kritiniai gamybiniai objektai, kuriems defektingumas didžiausias.
Į sluoksnius įterptoms asimetrijoms (įterpt.asim.) nurodomos į efektų komplektus įterptos asimetrijos.
Iš sluoksnių pašalintoms asimetrijoms (pašal.asim.) nurodomos iš efektų komplektų pašalintos asimetrijos.
Kritinėms asimetrijoms (Krit.asim.) nurodomi trys blogiausi parametrai ir jų vidutiniai defektingumo dydžiai. Pabaigoje nurodytas rūšiavimo (pasirinktas tikslo) parametras.
Optimumų dydžiai (opt.dydis) nurodomi pasirinktam tikslo bei kritiniam parametrams ir papildomai pateikiami egzistuojančio gamyboje suderinimo dydis (didžiausiam gaminių skaičiui su nurodytu parametru) bei skirtumas tarp optimumo ir esančio suderinimo bei skirtumas procentais nuo asimetrijos normos dydžio. Pabaigoje nurodomas opt. param. defektingumas. Jei dydžio vietoje nurodyti klaustukai ??, tai yra keli minimumai ir optimumas nenustatomas.
Optimumo kitimas (opt.kitimas) procentais nurodomas kai nagrinėjamu periodu keitėsi suderinimo dydis ir dėl to įvairiems dydžiams yra skirtingas matuojamos KS numerio vidurkis, lyginant su bendruoju vidurkiu. Šioje vietoje dar papildomai tas pat atliekama ir nurodoma matuojamos KS numerio išsibarstymui.
Kritiniams objektams (Krit.obj) (ar ENR, KNR, KIN, KON, JUS, LAI, FER, KOR, PAV, ENK, KNK, KNA, KNS, MAP) nurodomi aštuoni blogiausi atitinkamos rūšies objektų žyminiai ir jiems priskirti efektai. (pastaba: objekto žyminiui čia skirtos tik trys raidžių ar skaičių vietos ir imamos trys pirmosios raidės ar trys paskutinieji skaičiai)
Maksimalus KS Nr. vidurkio kitimas (MaxVidKitim.) nurodytam asimetrijų komplektui parodo objektus surikiuotus pagal vidurkio kitimo dydį nuo didžiausio.
Maksimalus KS Nr. išsibarstymo kitimas (MaxIssKitim.) nurodytam asimetrijų komplektui parodo objektus surikiuotus pagal išsibarstymo kitimo dydį nuo didžiausio.
Objektai su kitomis kritinėmis asimetrijomis (Krit.asim.??) nurodytam asimetrijų komplektui parodo tuos objektus, kurių kritinės asimetrijos yra kitos lyginant su bendrąja kritine asimetrija .
Maksimaliai nuo bendro optimumo nukrypę objektai (MaxNukrypObj) nurodytam asimetrijų komplektui parodo objektus, labiausiai nukrypusius nuo bendro optimumo.
Vienos rūšies kritiniai objektai (pvz. Krit.ENR obj) parodo vieno nurodyto tipo kritinius objektus.
Kritiniai objektai su efektais (Krit.obj+ef.) parodo kritinius objektus ir jų efektus iš visų objektų imties.

Optimalių parametrų grafikai


Ataskaitos

Galima pasirinkti įvairius ataskaitų ruošimo būdus. Pasinaudoti iš anksto suformuotomis ataskaitomis, kurios programiniu būdu užpildomos pasirinktais duomenimis, arba koreguoti senas, arba susikurti naujas ataskaitas.

Ataskaitų ruošiniai randasi VNES kataloge ir esant poreikiui, kopijuojami į darbinį katalogą.

Į programų kompleksą įtrauktos ataskaitos suformuotos Excel elektroninės lentelės pagalba. Naudojantis jomis yra atliekamas duomenų eksportas iš duomenų bazės, o ataskaitoje atliekamas šių duomenų importas. Pagrindinėse duomenų bazių naršyklėse yra realizuotas komandinis klavišas, automatiniu būdu atliekantis šias procedūras. Meniu komplektuose randasi duomenų eksporto punktai. Darbo režimų meniu komplekte yra Progr. darbo rėž. parametrai, kuriame yra nurodoma ataskaitų programa su ataskaitos ruošiniu (Gam. obj. atask.; Kontrol. atask.; Kontr. sur. atask.).

  • Duomenų eksportas
  • Ataskaitos duomenų importas

Pastabos: Norint suformuoti ataskaitą vienai KS, galima kelis kartus įvesti tos KS duomenis, bei paskaičiuoti visus statistinius parametrus ir tuomet suformuoti ataskaitą.

Kelių KS parametrų skirtumo ataskaitą galima suformuoti dviejų KS ataskaitų pagalba, kai trečios tuščios Excelio ataskaitos lentelės langeliuose nurodomas pirmųjų dviejų atitinkamų langelių skirtumas.

Pastabos esant dideliam duomenų kiekiui:

Excel XP el. lentelė palaiko 65536 eilučių. Dėl to geometrijos ataskaitoms turėtų būti atitinkamas duomenų apribojimas.

Tačiau kadangi ataskaitos elektroninė lentelė gana plati, priklausomai nuo kompiuterio konfigūracijos excel-iui pritrūksta atminties ir reikia apdoroti dalimis ar mažinti duomenų skaičių.

Atlikti bandymai su pent 4 1600MHz ir 1Gb RAM kompiuteriu bei 34000 KS duomenimis WIN XP aplinkoje. Excel-io skaičiavimai truko apie 10 min.

KS asimetrijų meniu komplekte yra Eksporto duomenų dalinimo procedūra, kuri padalina ir sugrupuoja geometrijos eksporto duomenis į atskirus failus.

Bandymai parodė, kad priimtina geometrijos duomenų apimtis turi būti tarp 7000 ir 15000 KS. Galima teigti, kad tokios apimties duomenų vidurkiai, išsibarstymai ir tinkamumo koeficientai nesiskiria ( kai duomenys iš generalinės imties imami vienodai iš kiekvienos sudėtinės imties ir yra išpildomos rondomizacijos sąlygos ).

(Papildomai žr. ataskaitos duomenų importas)


Ataskaitos duomenų importas

Ataskaitos (kartais vadinamos raportais) dažniausiai formuojamos Excel elektroninės lentelės pagalba. Kadangi dažnai ataskaitos kiekvienam gaminiui modifikuojamos pagal kliento poreikius, tai jos, kartu su atitinkamais duomenimis laikomos pagal atitinkamą gaminį pavadintuose kompiutriniuose kataloguose (direktorijose). Dėl to būtina nustatyti Excel-io programą taip, kad ji duomenis ieškotų ne kataloge pagal nutylėjimą - My Documents, o tame kataloge, kur randasi formuojama ataskaita. Tai atliekama Excel meniu pagalba - Tools - Options - General - Default file location: , kur šalia esantį langelį reikia ištrinti ir palikti tuščią.

Ataskaitos dažniausiai būna iš anksto paruoštos, tik reikia įsitikinti, kad darbiniame kataloge yra importuojamų duomenų bei ataskaitos failai ir paleisti atitinkamą ataskaitos programą (makrosą), kuri ne tik importuoja duomenis, bet ir atlieka kai kuriuos reikalingus skaičiavimus ir lentelių procedūras. Tam reikia su pele nuspausti atitinkamą mygtuką, arba susirasti meniu pagalba: Tools - Macro - Macros... , pasirinkti iš sąrašo ir paleisti Run klavišo pagalba.

Jeigu skleistinės (geometrijos) parametrų statistika skaičiuojama tos pačios ataskaitos pagalba ir duomenų skaičius yra didelis (daugiau 15000 KS), priklausomai nuo kompiuterio sudėties, gali užtrukti skaičiavimai daugiau 10 min. bei senesnės versijos Excel-is (pvz. iš Office 97) gali duoti pranešimą, kad pritrūko atminties. Tuomet skleistinės duomenis galima padalinti į kelias dalis (meniu KS asimetrijos - Ekspotro duomenų dalinimas) ir su pakankamu pasikliovimo lygmeniu paskaičiuoti statistiką. (Papildomai žr. ataskaitos)

DĖMESIO !!!

Kompiuteris turi būti konfiguruotas taip, kad suprastu skaitmeninius laukus su tašku vietoj kablelio. Ruošiant ataskaitas Excel elektroninės lentelės pagalba reikia iš Tools - Options - General ištrinti lauką Default file location, kad failai būtų ieškomi tame pačiame kataloge, kuriame dirba programa. Excel vieta ir ataskaitų paleidimo komandos turi būti nurodytos programos parametruose.


Optimalių parametrų skaičiavimas

OPTIMALIŲ parametrų grafikai

Meniu punkto XLS grafikai pagalba Excelyje formuojama grafinė priemonė optimalių parametrų ir gamybos objektų vaizdinei apžiūrai.
 Optimumo grafikų elektroninėse lentelėse realizuota vaizdinė galimybė ne tik pamatyti parametrų įtaką į optimumą, bet ir kiekvieno sluoksnio parametrų skaitmeninių verčių priklausomybę nuo pasirinkto tikslo parametro skaitmeninės vertės. Taip pat čia realizuota galimybė ne tik pamatyti objektų optimumų skirtumus, bet ir keisti objektų grafikų komplektus steko principu.

OPTIMALIŲ parametrų skaičiavimas

Optimalių parametrų analizė


Žodžių išaiškinimas

Santrupų ir kai kurių terminų išaiškinimas

Čia paaiškinami kai kurie panaudojami žodžiai bei duomenų bazių žyminiai. Greitesniam žodžių radimui naudok kairėje esantį rūšiuotą žodžių tūrinį - Index

"Minoltos" matuoklis- nesusivesties ir skleistinės matavimo įrenginys su viena videokamera, jungiamas su kompiuteriu ir televizoriumi bei matuojantis tik vienoje iš kineskopo ekrano zonų. Su juo galima panaudoti senus 286 tipo kompiuterius. Pakanka 30Mb kieto disko vietos programoms ir duomenims, lanksčiojo disko įrenginio duomenų užrašymui į disketes ir COM tipo jungties "Minoltos" matuoklio prijungimui. Šio matuoklio duomenų failai būna su pavadinimo plėtiniu .min.

"Vingelio" įrenginys- nesusivesties ir skleistinės matavimo įrenginys su devyniomis videokameromis, jungiamas su kompiuteriu bei matuojantis tik devyniose kineskopo ekrano zonose. Jame panaudojamas naujesnio tipo kompiuteris. Šio matuoklio duomenų failai būna su pavadinimo plėtiniu .txt.

Kamayos matuoklis - nesusivesties ir skleistinės matavimo įrenginys su devyniomis videokameromis, jungiamas su kompiuteriu bei matuojantis ne tik devyniose kineskopo ekrano zonose, bet gali ir 81. Jame panaudojamas naujesnio tipo kompiuteris. Šio matuoklio duomenų failai būna su pavadinimo plėtiniu .csv.

IPS matuoklis - nesusivesties, skleistinės ir spalvų švarumo matavimo įrenginys su viena videokamera ir komplektuojamas su vidiniu kompiuteriu. Šio matuoklio duomenų failai būna su pavadinimo plėtiniu .csv.

Stefanovičiaus programos - programos, skirtos KS duomenų apdorojimui daugiau konstruktyviniu profiliu. Bendrovės kompiuteriniame tinkle galima rasti vardu \\Sstanisl\visiems\ . Duomenų failo plėtinys .vdt.

Gamybos objektai- staklės, laikikliai, įspraustinės, laidų tiekėjai, kineskopai, barai, operatoriai ir kiti objektai, dalyvaujantys gamybos procese ir registruojami atitinkamomis kompiuterinėmis programomis atitinkamose duomenų bazės lentelėse ar kt. rinkmenose (failuose).

Kontrolinis surinkimas - kontr. sur. - periodiškas gamybos proceso ar objekto tikrinimas, ar jis neišsiderino ir ar nereikia pareguliuoti ar imtis kitų priemonių. Šis tikrinimas naudojamas kai ne visų gaminių parametrai yra kontroliuojami, ar kai gamybos procesas užtrunka taip ilgai, kad kol patikrinami parametrai, gamybos procesas gali išsiderinti ir gali būti pagaminti nekokybiški ruošiniai.

Dos - kompiuterio simbolinės darbo aplinkos (SDA) operacinė sistema.

Failo plėtinys - informacijos laikymo kompiuterio kaupiklyje rinkmenos (failo) pavadinimo galutinė dalis, atskirta nuo pradinės dalies tašku, pagal kurią kompiuterinės programos identifikuoja tos rinkmenos šaltinį ir struktūrą. Plėtinys dažniausiai susideda iš trijų raidžių.

Programos forma - kompiuterinės programos dizaino komponentas, skirtas duomenų parodymui ar redagavimui ir pritaikytas dirbančio operatoriaus patogumui ir geresniam tų duomenų supratimui.

Windows -kompiuterio grafinės darbo aplinkos (GDA ) operacinė sistema.

MS Office – biuro dokumentų ruošimo GDA programų kompleksas.

Norton ar Windows comander ar Far - darbo su failais ir tinklais programų kompleksas.

Quattro - elektroninės lentelės SDA programų kompleksas.

Excel - elektroninės lentelės GDA programų kompleksas.

Clarion - duomenų bazės valdymo SDA programų kompleksas.

Qbasic - "Minoltos" matuoklio aprašyme rekomenduojama kompiuterinė SDA programavimo kalba.

Visual FoxPro - duomenų bazės valdymo GDA programų kompleksas.

Komandinis mygtukas - programos formos elementas, paprastai su pavadinimu, kurį nuspaudus su kompiuterio pele vykdoma atitinkama programos komanda ar procedūra.

Loginis žymeklis [image] - programos formos loginis elementas, kuri bakstelėjus su pele, pažymimas paukščiukas arba jis nuimamas ir tokiu būdu gali būti nurodoma atlikti ar neatlikti kokias nors procedūras.

DB – duomenų bazė su lentelių komplektu, į kurias rašoma atitinkamos rūšies informacija. Lentelės turi stulpelius, kurie vadinami laukais ir turi laukų pavadinimus, bei turi eilutes, kurios vadinamos įrašais ir kurių kiekis priklauso nuo įrašytos informacijos kiekio.

Zip – kompiuterinių duomenų archyvo žyminys ir failo plėtinys.

El. lent. – kompiuterinių ataskaitų ruošimo elektroninė lentelė.

Help – programų komplekso pagalbos sistema, programoje gali būti prieinama su F1 klavišu ar meniu pagalba.

Pkzip.exe – kompiuterinės informacijos archyvavimo (suspaudimo) programa.

VNES - kompiuterio inf. kaupiklio - kietojo disko direktorijos pavadinimas - vieta kur saugomos programos, duomenys ir rezultatai bei ataskaitos, suformuotos čia aprašytais metodais.

KS ar DY – kreipiamoji sistema, skirta televizorių kineskopo spindulių elektromagnetiniam kreipimui (lankstymui) ir spalvoto vaizdo gavimui ekrane.

EOP - elektroniniai-optiniai parametrai - kineskopo ekrane gaunamo vaizdo iškraipymai, sąlygoti kineskopo ir KS elektromagnetinės sistemos netobulumų - konstruktyvinių, metrologinių ir gamybinų netikslumų, kurie savo ruožtu gali būti neišvengiami arba valdomi bei dėsningi ar atsitiktiniai.

NES ar N - nesuvestis - KS elektroninių optinių parametrų rūšis - spalvotų spindulių pedsakų nesutapimas kineskopo ekrane.

Q9 ir Q25 - atitinkamai 9 pagrindinėse ar visose 25 ekrano zonose išmatuotų nesuvesties koordinatinių duomenų su įtakos svorio koeficientais geometrinė suma - bendras nesuvesties įspūdis.

AST - astigmatizmo parametrai (žalio ir mėlyno su raudonu spindulių).

KOM - komos parametrai (raudono ir mėlyno spindulių).

DIS - distorsijos arba skleistinės geometrinių iškraipymų parametrai - vaizdo kontūro geometriniai iškraipymai.

Balansas - vienas iš skleistinės iškraipymo parametrų, priklausantis nuo KS eilučių ritelių pasukimo atžvilgiu kineskopo ir pasireiškiantis tos pačios krypties (laikrodžio rodyklės ar priešinga kryptimi) nukrypimu nuo horizontalios ekrano ašies.

X1, Y1 iki X9, Y9 - AST, KOM ar DIS nesuvestis horizontalia ir vertikalia kryptimis kampuose, ant ašių ir ekrano centre.

ASI ar P - asimetrijų parametrai, surikiuoti pagal efektus.

P01 iki P08 - asimetrijų parametrai (efektai) ant ekrano ašių, horizontalia ir vertikalia kryptimis.

P09 iki P16 - asimetrijų parametrai (efektai) ekrano kampuose, horizontalia ir vertikalia kryptimis.

P17 iki P24 - asimetrijų parametrai (efektai) ekrano kampuose, įžambinių kryptimis.

P25 iki P40 - asimetrijų anizotropijos parametrai (efektai).

DEF ir Normo - defektingumas ir brokavimo riba.

PAT, Patai - pataisa, kurą reikia pridėti prie nesuvesties matavimo rezultato - priešingo ženklo dydis paklaidai.

Tiksl - tikslinis asimetrijos parametrų dydis, taikinys (target), prie kurio reikia artinti gamybos procesą.

Stati - statiniai centro nesuvesties įtakos korekcijos koeficientai, reikalingi centrinės nesuvesties įvertinimui kitose zonose.

S0, S1, S2, S3 - kineskopo ekrano matavimo zonų komplektai (išorinės, tarpinės zonos).

Statistika - statistinių parametrų rinkinys. Šioje programoje naudojami vidurkiai (vidutinės reikšmės); išsibarstymai (kokie nukrypimai nuo vidurkio); gamybos tinkamumo koeficientai (Cpk, ar yra pakankamos gamybos atsargos, turi būti >1,33); defektingumo procentas (parametro išėjimo už užduotų ribų (normų, limitų) tikimybė).

Dinamika - mažos, vidutinės ir didelės imties statistiniai parametrai, parodantys kaip jie keičiasi bėgant laikui.

X1, X2, X3 - mažos, vidutinės ir didelės imties vidurkiai

Z1, Z2, Z3 - mažos, vidutinės ir didelės imties išsibarstymai.

C1, C2, C3 - mažos, vidutinės ir didelės imties gamyb.tinkamumo koeficientai.

B1, B2, B3 - mažos, vidutinės ir didelės imties prognozuojamas defektingumas procentais.

Komp. - kompiuteris.

Kont.- kontaktas.


Istorija

Mokymas

Čia išvardijamos kai kurios priemonės skirtos darbo su programa mokymui.

Kompiuterinių video failų komplektas prnega programai:

1.Paleidimas.avi

2.DBinstal.avi

3.DarboRezimai.avi

4.AsimNorm.avi

5.OptAsim.avi

Kompiuterinių video failų ir straipsnių kopijų komplektas Excel elektroninei lentelei:

1.divx_excel_lenteles.avi

2.divx_excel_grafikai.avi

3.OfficeExcel.JPG

Statistikos brošiūros:

1.Engineering Statistics.chm

2.Iesthome.chm

3.STATGlossary.chm

4.ISO_2859-1.chm


Istorija

Čia išvardijami svarbiausi programos projektavimo ir papildymo etapai.

2006 10 Programos termino pratęsimas ir tobulinimo bei naujinimo sąlygų pakeitimas ryšium su autorinių sąlygų pasikeitimu.

2005 10 Optimalių asimetrijų analizės rezultatų apžvalgos patobulinimas.

2005 08-09 f. THOMPSON ataskaitos (raporto) formavimo automatizavimas.

2005 07 Programų komplekso papildymas f. THOMPSON specifikacijai su papildomais asimetrijų ir geometrijos tarpinėse zonose parametrais.

2004 07-2005 01 Gamybos įrengimų derinimo duomenų bazės ir duomenų įvedimo, atrankos bei skaičiavimo procedūrų įtraukimas į programą. Neuroninių tinklų ir faktorinės analizės bandymai.

2004 06 Asimetrijų optimalių normų skaičiavimo procedūrų įtraukimas į programą.

2004 04 Atlikti tyrimai, sukurtos programos ir papildymai pagal sutartį su VU Matematikos ir informatikos fakulteto Matematinės statistikos katedra.

2004 01 Pasirašyta sutartis su VU Matematikos ir informatikos fakulteto Matematinės statistikos katedra. Bendradarbiavimas suintensyvėjo. Atliekami asimetrijų optimalių normų tyrimai.

2003 12 Optimumo algoritmas pristatytas Panevėžio "Ekrano" mokslinėje-techninėje konferencijoje.
Suformuotos programos asimetrijų normų ir optimalių asimetrijų vaizdinėms priemonėms. Atliekami bandymai ir koregavimas.

2003 11 Programa papildyta optimalių asimetrijų skaičiavimo procedūromis gamybos objektams. Pradėti bandymai įvairiems gaminiams ir programų koregavimas.

2003 10 Šalia eksporto procedūros suformuota analogiška importo galimybė.

2003 09 Papildyti Kamajos duomenų variantų algoritmai.

2003 07 Atlikta KS2180 asimetrijų statistinė analizė, nustatyti optimalūs parametrai ir nustatytos gairės gamybos kokybės valdymo programų papildymui. Gautas panaudojamos metodikos VU statistikos fakulteto atstovų patvirtinimas .

2003 05 Pakoreguotos ir sugriežtintos pradinių duomenų pagal nutylėjimą ir parametrų normų reikšmės. Papildyti Kamajos duomenų struktūros variantai

2003 04 Pradėta statistinė surinktų matavimo duomenų analizė ir duomenų ruošimas VU matematinės statistikos katedrai.

2003 03 Patobulintas programos apsaugos algoritmas.

2003 02 Suformuotas ir pritaikytas procedūroms duomenų kiekio indikatorius.

2003 01 Sukurta forma ir išplėstos .dbf duomenų eksporto galimybės.

2002 12 Aptartos bendradarbiavimo su VU gairės.

2002 10 Išplėstas .vdt duomenų struktūros variantų skaičius.

2002 09 Pirminių duomenų rinkinių formavimas Kamajos, Minoltos, IPS ir .vdt matuoklių duomenims.

2002 08 Kamajos duomenų struktūros pakeitimai.

2002 05 PRNEGA progrmos paleidimo ir pradinių duomenų kompiuterinių video failų formavimas.

2002 04 Vingelio matuoklių duomenų rinkinio formavimas ir paketinis apdorojimas.

2002 03 Klaidingų pradinių duomenų valdomas filtras.

2002 02 Naujų papildomų parametrų Q9 ir Q25 įterpimas.

2001 12 PRNEGA helpo projektavimo pradžia.

2001 11 Programos pradinių sisteminių duomenų administravimo forma.

2001 10 Kontrolinių surinkimų ataskaitos parametrų pasirinkimas.

2001 08 Kontrolinių surinkimų DB, apdorojimas ir formos bei ataskaitos.

2001 06 Vienos KS exelio ataskaita.

2001 04 Kamaya matuoklio duomenų importas ir apdorojimas.

2001 03 Pirminių duomenų pataisų reakcija į matuojamų zonų komplektą.

2001 02 Profilaktinis pirminių duomenų šalinimas.

2001 01 IPS duomenų struktūros pakeitimai.

2000 12 Gamybos objektų DB profilaktinis perrūšiavimas ir duomenų atstatymas.

2000 06 Filipso ataskaitų papildymai.

2000 05 Tomsono duomenų panaudojimas ir ataskaitos.

2000 02 Samsungo ataskaitų papildymai.

2000 01 Programų koregavimas naujam tūkstantmečiui.

1999 Gamybos objektų mėnesio rezultatų kaupimas. Pataisų reagavimas į zonų komplektus. Ataskaitų pritaikymas dideliems duomenų kiekiams. .vdt duomenų importas. Elintos duomenų importo ir skaičiavimo algoritmų pasirinkimas. Taikymai Filipso duomenims.

1998 Programų taikymas Slovakams.

1997 Windowsinės programos projektavimo pradžia VFP pagalba. Prezentacijų formavimas.

1996 Minoltos matuoklio prijungimas prie kompiuterio ir parametrų nuskaitymo programavimas.

1995 Kontrolės DOSinių programų projektavimas.

1992 DOSinės programos personaliniam kompiuteriui projektavimo pradžia.

1986 Skaičiavimo technikos panaudojimo pradžia.

1976 KS parametrų analizės ir sistematizavimo darbų pradžia. Statistikos panaudojimas. Bendradarbiavimas su VU.


Nuorodos

Nuorodų ir literatūros sąrašas

Įmonės standartų sąrašas

Gaminių specifikacijų sąrašas

Metodinių instrukcijų sąrašas

ĮST 2259783-231:1996 "Kreipiamosios sistemos. Specifikacija".

LST EN ISO 9001:1995 "Kokybės sistema. Kokybės užtikrinimo projektuojant, tobulinant, gaminant, įrengiant ir prižiūrint modelis".

MI 05.051-98 "Duomenų konfidencialumo užtikrinimas personaliniuose kompiuteriuose".

Su Vilniaus Universitetu atlikti tiriamieji darbai: AB "Vilniaus Vingis" komp. tinklas

"Lietuviškas spalvinis kineskopas. Plačiaekranių kineskopų perspektyvos." AB "Ekranas" 2004. Konferencijos medžiaga.

"Lietuviškas spalvinis kineskopas. Konstrukcija, technologija, kokybė." AB "Ekranas" 2000. Konferencijos medžiaga.

http://www.itl.nist.gov/div898/handbook/ Engineering Statistics Handbook

M.Adomėnas "Statistinių metodų taikymas kokybės sistemose", Kaunas, 1994.

Tuv-Uolektis "Statistiniai kokybės užtikrinimo metodai", Kaunas, 1994.

Vidas Čepulis "Elektroninė optika", Kaunas, Technologija, 2001

"Kreipimo sistemų magnetinių laukų ir kreipimo aberacijų teorijos elementai".

"Kursas apie spalvoto vaizdo kreipimo sistemas"

"CRT convergence meter CC-100".

Vygintas Šakys "Skaičiuoklė Microsoft EXCEL 97 firmos vadybai", Kaunas PIF l-kla, 1998.

"Using Visual FoxPro 6" Menachem Bazian, Jim Booth, Jep Long, Vin Miller, Celia Silver, Robert A. Byers Que Corporation 1998.

“Пакет электронных таблиц QUATTRO PRO “, Обнинск ,1994.

И.М.Терентьев “CLARION 2.1 для пользователя и программиста” ,Москва ,1995.

Ю.Л. Кетков “GW-, Turbo- и Quick-BASIC для IBM PC”, Москва, 1992.